Opened 11 years ago

Closed 10 years ago

#7263 closed enhancement (duplicate)

Add tests to have model based subgrid in dojox/grid/tests

Reported by: raghubetter Owned by: Nathan Toone
Priority: high Milestone: future
Component: DojoX Grid Version: 1.0
Keywords: Cc:
Blocked By: Blocking:

Description

the subgrid example lacks the ability to take a model, because its an attribute we cannot have two models in same grid definition in the div, loading it. secondly we would need to have multiple rows from different data sources, so that the subgrid can be rendered easily and independently without any support from the main grid.

Change History (5)

comment:1 Changed 11 years ago by raghubetter

the tests will be able to help developers like me to get an idea of the working and make changes accordingly.

comment:2 Changed 11 years ago by Bryan Forbes

Milestone: tbd1.2

comment:3 Changed 11 years ago by Nathan Toone

Milestone: 1.2future
Priority: highnormal

comment:4 Changed 11 years ago by Nathan Toone

Owner: changed from Bryan Forbes to Nathan Toone

Reassigning to me

comment:5 Changed 10 years ago by Nathan Toone

Resolution: duplicate
Status: newclosed

The grid doesn't really handle subgrids well. You really can't do it with a model. However, we are working on a "Tree Grid" widget (see #7402).

Closing this bug as a duplicate of #7402 - since when that one lands, we'll be able to create such test cases.

Note: See TracTickets for help on using tickets.