Opened 11 years ago

Closed 11 years ago

#7255 closed defect (worksforme)

Error on dijit.Editor.destroy()

Reported by: igel Owned by: liucougar
Priority: high Milestone: tbd
Component: Editor Version: 1.1.1
Keywords: Cc:
Blocked By: Blocking:

Description

After creating the Editor, Firefox reports 'Permission denied to get property XULElement.accessibleType'.

I have to remove the widget after some time because it is no longer needed. When I call destroy(true) or destroyRecursive(true) I get an error like 'this.toolbar is undefined' and my application stops.

If I circumvent this by try/catch and create another Editor afterwards, the application stops with the error method 'this.toolbar is undefined'.

On other browsers (Opera, Safari) I had similar errors. Looks like Ticket #6028 is reproducable on Firefox 3.

If I use false as argument, the result is the same.

(All messages are shown in firebug).

Change History (3)

comment:1 Changed 11 years ago by liucougar

can you provide a test case for this?

comment:2 Changed 11 years ago by igel

create var area = dojo.byId("dojotFreeTextArea"); var editor = new dijit.Editor({}, area); editor.startup();

destroy this.editor.close(false, false); this.editor.destroyRecursive(true);

comment:3 Changed 11 years ago by bill

Resolution: worksforme
Status: newclosed

I suspect the second error is related to the first one, but I can't reproduce the first error. Creating an editor works fine for me, see http://download.dojotoolkit.org/release-1.2.0rc1/dojo-release-1.2.0rc1/dijit/tests/test_Editor.html.

destroy() is also working, as per that test above (there's a button for destroy).

Note: See TracTickets for help on using tickets.