Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#7248 closed defect (fixed)

TabContainer: Hover Over Close Button for Left/Right Aligned Tabs Does Not Update Tab Sprites Completely

Reported by: fobulous Owned by: nonken
Priority: high Milestone: 1.2
Component: themes Version: 1.1.1
Keywords: TabContainer Cc:
Blocked By: Blocking:

Description

This issue can be found under using Soria and Nihilo. Tabs must be aligned left or right to reproduce bug. Hovering over the close button of a closable tab that is aligned left of right does not replace the sprite closest to the content pane. The effect produces a tab whose "hover" look is not complete since part of the "enabled" sprite is visible. The fix found to correct this issue is as follows.

For left alignment: (1) find:

.desmo .dijitAlignLeft .dijitTabHover .dijitTabInnerDiv

(2) replace with:

.desmo .dijitAlignLeft .dijitTabHover .dijitTabInnerDiv, .desmo .dijitAlignLeft .dijitTabCloseButtonHover .dijitTabInnerDiv

For right alignment: (1) find:

.desmo .dijitAlignRight .dijitTabHover

(2) replace with:

.desmo .dijitAlignRight .dijitTabHover .desmo .dijitAlignRight .dijitTabCloseButtonHover

-gtducati-

Change History (4)

comment:1 Changed 11 years ago by Adam Peller

Owner: changed from dante@… to dante

comment:2 Changed 11 years ago by bill

Owner: changed from dante to nonken
Summary: Hover Over Close Button for Left/Right Aligned Tabs Does Not Update Tab Sprites CompletelyTabContainer: Hover Over Close Button for Left/Right Aligned Tabs Does Not Update Tab Sprites Completely

comment:3 Changed 11 years ago by nonken

Resolution: fixed
Status: newclosed

Fixed in tab cleanup, fixes #7155

comment:4 Changed 11 years ago by Adam Peller

Milestone: tbd1.2
Note: See TracTickets for help on using tickets.