Opened 11 years ago

Closed 11 years ago

#7239 closed defect (wontfix)

[dojox.form] Duplicate widgets?

Reported by: dante Owned by: Mike Wilcox
Priority: high Milestone: 1.2
Component: DojoX Form Version: 1.1.1
Keywords: Cc: dante, Mike Wilcox
Blocked By: Blocking:

Description

There is a dojox.form.FileInputBlind? widget that does seemingly the same thing as dojox.form.FileInputOverlay? -- a lot of the code in Overlay is reproduced in the FileInput? base class. Consider moving that stuff out.

Change History (4)

comment:1 Changed 11 years ago by dante

Cc: Mike Wilcox added

comment:2 Changed 11 years ago by Mike Wilcox

FileInputBlind? creates a button - FileInputOverlay? allows you to provide a custom button. This is pretty important - most projects are going to request some kind of custom button.

In FileInputBlind?, you can't even realistically change the label of the button (unless the label is the same character amount as "Browse..."), because the real fileInput is not being resized.

FileInputBlind? is unique however, in that it has a progress bar and a cancel button option.

I propose that FileInput? (and therefore FileInputBlind? and FileInputAuto?) be refactored to inherit from FileInputOverlay? (I was in fact originally going to name it FileInputBase? - but that lacked description).

Most of the effort in FileInputOverlay? was in getting the CSS to work - and there's a lot to consider when the page gets complicated and the fake button has a float or a relative or something.

comment:3 Changed 11 years ago by Mike Wilcox

Milestone: future1.2
Owner: changed from Nathan Toone to Mike Wilcox

comment:4 Changed 11 years ago by Mike Wilcox

Resolution: wontfix
Status: newclosed

Changed widget name to FileUploader?, utilizes FlashUploader? that sets it more apart from the others. http://trac.dojotoolkit.org/browser/dojox/trunk/form/FileUploader.js

Note: See TracTickets for help on using tickets.