Opened 13 years ago

Closed 13 years ago

Last modified 12 years ago

#722 closed defect (fixed)

IE 6 locks up on all examples

Reported by: moc dot oxalp @… Owned by: Dustin Machi
Priority: high Milestone:
Component: Website Version: 0.3
Keywords: Cc:
Blocked By: Blocking:

Description

Similar to http://trac.dojotoolkit.org/ticket/608 but different symptoms.

Browse to any of the examples on the main page using IE 6

CPU goes to 100% and no page is displayed.

(IE 6 == all current patches on XP, displayed version is 6.0.2900.2180.xpsp_sp2_gdr.050301-1519)

Window internal content does change size, as new scrollbars show up and/or expand. After that happens, page is locked and IE is completely unresponsive.

It's doing something because it continues to PF and memory usage increases at about 2mb/minute, but it never times out and doesn't display the page even after 10 minutes.

May be unrelated, but main dojotoolkit.org page never completes loading under IE6, it is hung up waiting for 1 image from yimg.

Reverse e-mail to contact me.

Change History (13)

comment:1 Changed 13 years ago by Tom Trenka

Component: GeneralWebsite
Version: 0.3

r moore--

Could you be more specific? We tested this last night pretty hard with IE 6 on both XP and 2k3, and didn't find the issues you were having. In fact, I just tried again (IE6/XPSP2) and had no issues.

Was there something specific in the demos you clicked on to get the browser to freeze?

comment:2 Changed 13 years ago by rmoore

Open IE6 Go to http://dojotoolkit.org/ Click on See it in action Click on Layout Widgets On the 1st item (Layout), click on View Demo

Pauses for about a second, window content resizes (a.k.a. I get scrollbars), then it goes to 100% and stays there.

Have cleared cookies/cache, still not working right. Works beautifully under FF 1.5.0.3 on same machine.

Will try to test on another machine this afternoon/evening.

comment:3 Changed 13 years ago by rmoore

Ran on another machine with similar but not identical IE/patchlevel, same problem present. Second test machine had hyperthreading, so it only maxed out to 50% CPU, but still no page displayed and same general symptoms for scrollbar.

comment:4 Changed 13 years ago by anonymous

Confirmed on two more, 6.0.2800.2180.xpsp.050622-1524 (not completely up-to-date on patches) and another match to 6.0.2900 above.

comment:5 Changed 13 years ago by rmoore

Individual tests appear to work, looks like it's a problem with the calls to get to them?

This works fine: http://dojotoolkit.org/dojo/tests/widget/test_Layout.html

comment:6 Changed 13 years ago by dwebsubmit@…

Same thing here.6.0.2900.2180.xpsp_sp2_gdr.050301-1519 on xp pro. Update versions:;SP2;

  • I click on the 'see it in action' tab
  • click on a category
  • click on view demo

and the browser is done.

I tried on 2 different machines with the same result. it tries to load some images and seems to go into an infinite loop between soriaButton-c.gif soriaButton-r.gif soriaButton-l.gif It looks for them in http://www.dojotoolkit.org/dojo/src/widget/templates/images/ The images are in there, though. But that infinite loop is the problem. Hope that helps.

I can see the "live demo" link at the bottom of the page.

Diego

comment:7 Changed 13 years ago by anonymous

Version: 0.3

i'm seeing the same thing

comment:8 Changed 13 years ago by bill

Milestone: 0.3.1

comment:9 Changed 13 years ago by rmoore

Not sure the best way to see the unpackaged script/behavior, but in the current dojo.js, the event system looks like it's passing an event recursively: lines 1912 through 1941 are called ad infinitum. That's why it never gives the "this script has run too long, do you want to abort?" message, it's passing events instead of directly running the functions.

It's getting down to evt=window.event in the else block, then dispatching with a dojo.event.browser.fixEvent call in the if(evt) block on line 1931.

comment:10 Changed 13 years ago by Tom Trenka

Owner: changed from anonymous to Dustin Machi

Ok, I'm going to reassign this to dmachi and we'll see if we can figure it out.

comment:11 Changed 13 years ago by rmoore

Appears to be resolved, any idea what changed?

comment:12 Changed 13 years ago by Dustin Machi

Resolution: fixed
Status: newclosed

new demoEngine resolves this particular problem. However there still may be a bug related to IE and setOpacity.

comment:13 Changed 12 years ago by (none)

Milestone: 0.3.1

Milestone 0.3.1 deleted

Note: See TracTickets for help on using tickets.