Opened 11 years ago

Closed 10 years ago

#7184 closed defect (fixed)

Tree drag-n-drop will fail if we drag-n-drop a node out of the tree hierarchy.

Reported by: binspaul Owned by: bill
Priority: high Milestone: 1.3
Component: Dijit Version: 1.1.1
Keywords: Tree Cc:
Blocked By: Blocking:

Description

Error description :

The tree drag-n-drop will fail if we drag and drop a node out of the main tree hierarchy. The node will get detached from the tree and will follow the mouse pointer. The issue is also present in the example file : dijit/tests/tree/test_Tree_DnD.html.

Setps to replicate :

Take the "test_Tree_DnD.html" file and click on the "Orange" node. Now drag that node to the top-left of the enclosing box and release the mouse. The node will get detached from the tree and will become an orphan.

Possible reason :

The issue is that the "node" variable is getting a null value in that case and it is not checked. "node is null" error is printed on the console.

Regards,

Binu Paul <binu at amtindia.co.in>

Attachments (1)

ErrorScreen.gif (9.0 KB) - added by binspaul 11 years ago.
Screen shot illustrating the issue.

Download all attachments as: .zip

Change History (4)

Changed 11 years ago by binspaul

Attachment: ErrorScreen.gif added

Screen shot illustrating the issue.

comment:1 Changed 11 years ago by bill

Milestone: tbd1.4
Owner: set to bill

comment:2 Changed 11 years ago by bill

Milestone: 1.41.5

bumping 1.4 tickets to 1.5, and most 1.3 tickets to 1.4

comment:3 Changed 10 years ago by bill

Milestone: 1.51.3
Resolution: fixed
Status: newclosed

This is fixed in the latest code, at least by my test. Please reopen if you are still seeing the problem, and list which browser you saw the problem in.

Note: See TracTickets for help on using tickets.