Opened 11 years ago

Closed 10 years ago

#7174 closed defect (wontfix)

TabContainer: caret bleeds through after switching pane (IE)

Reported by: Les Owned by:
Priority: high Milestone: 1.5
Component: Dijit Version: 1.1.1
Keywords: Cc: Becky Gibson
Blocked By: Blocking:

Description (last modified by bill)

Steps to recreate:

  1. Enter http://dojotoolkit.org/demos/email-using-1-0
  2. Create a New Message
  3. Place cursor in the To: input
  4. Click the Inbox tab
  5. The cursor (by the Folders label) is in the wrong position.

This occurs only in IE. I tested it using IE6.

Attachments (1)

cursorBleedThrough.png (8.3 KB) - added by bill 11 years ago.

Download all attachments as: .zip

Change History (5)

Changed 11 years ago by bill

Attachment: cursorBleedThrough.png added

comment:1 Changed 11 years ago by bill

Cc: Becky Gibson added
Description: modified (diff)
Milestone: 1.21.4
Summary: IE bug - misplaced cursorTabContainer: cursor bleeds through after switching pane

This still happens in the nightly. Not sure how to fix it. Maybe changing the tab should blur any focus, or focus on the tab label, or focus on the first thing in the newly selected tab?

comment:2 Changed 11 years ago by bill

Description: modified (diff)

comment:3 Changed 11 years ago by bill

Milestone: 1.41.5

bumping 1.4 tickets to 1.5, and most 1.3 tickets to 1.4

comment:4 Changed 10 years ago by bill

Resolution: wontfix
Status: newclosed
Summary: TabContainer: cursor bleeds through after switching paneTabContainer: caret bleeds through after switching pane (IE)

Realistically, I don't think we'll get around to fixing this. It goes away in IE8 (and IE7 I guess), so the problem is sort of going away by itself.

Note: See TracTickets for help on using tickets.