Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#7161 closed defect (fixed)

BorderContainer has extra space when gutter="false"

Reported by: slickt10 Owned by: bill
Priority: high Milestone: 1.2
Component: Dijit Version: 1.1.1
Keywords: BorderContainer gutter Cc: nick4jesus@…
Blocked By: Blocking:

Description

The included document is a slimmed layout but illustrates the same problem. When you try to eliminate gutters the center disappers. Above the embeded bordercontainer theres a 25px space that can not be elimnated regaurdless of gutter state and was not a problem in a previous build. This seems to be related to the addition of gutters.

This is using the code from trunk as of 1:00pm 07/11/2008. I haven't been able to try this in other browsers to see if its an issue (This happens in ie6)

Attachments (1)

test2.htm (11.4 KB) - added by slickt10 11 years ago.
example

Download all attachments as: .zip

Change History (5)

Changed 11 years ago by slickt10

Attachment: test2.htm added

example

comment:1 Changed 11 years ago by bill

Owner: set to bill
Status: newassigned

comment:2 Changed 11 years ago by bill

Resolution: fixed
Status: assignedclosed

(In [14410]) Fix regression from [14392] breaking gutters=false. Refs #6438, fixes #7161.

comment:3 Changed 11 years ago by liucougar

(In [14418]) refs #7161: fixes broken BC if gutter=false and no parameter is passed to the constructor !strict

comment:4 Changed 11 years ago by bill

(In [14426]) Rollback accidental checkin of experimental change in [14410]. Fixes #7166, refs #6438, #7161.

Note: See TracTickets for help on using tickets.