Opened 11 years ago

Closed 11 years ago

#7147 closed defect (fixed)

Typo in TablePlugins.js file breaks build process

Reported by: ptwobrussell Owned by: Mike Wilcox
Priority: high Milestone: 1.2
Component: Editor Version: 1.1.1
Keywords: Cc: ptwobrussell@…
Blocked By: Blocking:

Description

If you try to do a build with the latest revision, it bombs out. Here's the relevant part of the stack trace:

release: ../../release/blarg/dojox/editor.plugins/resources/insertTable.html org.mozilla.javascript.WrappedException?: Wrapped java.io.FileNotFoundException?: ../../release/blarg/dojox/editor.plugins/resources/insertTable.html (No such file or directory)

The issue is that the "editor.plugins" portion of the moduleUrl needs to be "editor/plugins" on lines 821 and 880 of the TablePlugins?.js file. (Looks like a simple typo.)

I'll tag this as high/major since this issue has a potentially wide side-effect, and since SitePen? just released an AIR app that automates builds (and this might break it?).

Change History (2)

comment:1 Changed 11 years ago by bill

Milestone: tbd1.2
Owner: changed from liucougar to Mike Wilcox

comment:2 Changed 11 years ago by Mike Wilcox

Resolution: fixed
Status: newclosed

Thanks to Bryan's help, we got it fixed. bad moduleUrl. Somehow I was able to commit without Ref'ing this ticket. Consider it ref'ed.

Note: See TracTickets for help on using tickets.