Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#7123 closed defect (fixed)

BorderContainer: Tab container in nested BorderContainer default sizing issue

Reported by: nonken Owned by: bill
Priority: high Milestone: 1.2
Component: Dijit - LnF Version: 1.1.1
Keywords: TabContainer, nested, resizing Cc: bill, nonken
Blocked By: Blocking:

Description

When having tabs within BC within BC their initial sizing seems to be taking some padding or so into account. After resize of browser window it adjusts correctly

Attachments (1)

sizingtabs.png (28.1 KB) - added by nonken 11 years ago.

Download all attachments as: .zip

Change History (4)

Changed 11 years ago by nonken

Attachment: sizingtabs.png added

comment:1 Changed 11 years ago by bill

Milestone: tbd1.2
Owner: set to bill
Status: newassigned
Summary: Tab container in nested BorderContainer default sizing issueBorderContainer: Tab container in nested BorderContainer default sizing issue

Actually the problem is with a BorderContainer inside a TabContainer.

comment:2 Changed 11 years ago by bill

Resolution: fixed
Status: assignedclosed

(In [14348]) Fix sizing problem when BorderContainer?.resize(size) was called (w/a size argument) on content-box sizing browsers (i.e., everything but IE). Need to do padding hack before _LayoutWidget.resize(size) is called, because it affects the value we pass to dojo.marginBox() to set the size of the widget. Fixes #7123 !strict.

comment:3 Changed 11 years ago by bill

oops, checkin comment was inaccurate... should have said that we need to modify the widget's padding before we set the margin-box size (in _LayoutWidget.resize())... otherwise when changing the padding inadvertently changes the margin-box size.

Note: See TracTickets for help on using tickets.