Opened 11 years ago

Closed 11 years ago

#7118 closed defect (duplicate)

[fx] error in chaining _Animations from a combine

Reported by: gruppler Owned by: Bryan Forbes
Priority: high Milestone: tbd
Component: fx Version: 1.1.1
Keywords: chain, combine, onAnimate, array Cc:
Blocked By: Blocking:

Description

When chaining two animation objects from dojo.fx.combine, the onPlay doesn't fire, and I get this error message:

exception in animation handler for: onAnimate
TypeError: second argument to Function.prototype.apply must be an array

Changing line 14 in dojo/fx.js from...

this[evt].apply(this, args||[]);

to...

this[evt].apply(this, (dojo.isArray(args) ? args : []));

silences the error, but the onPlay still does not fire.

Combining two chains, on the other hand, works perfectly. Attached is an example of a chain of two combines and a combine of two chains.

Attachments (1)

chain_test.js (811 bytes) - added by gruppler 11 years ago.

Download all attachments as: .zip

Change History (2)

Changed 11 years ago by gruppler

Attachment: chain_test.js added

comment:1 Changed 11 years ago by dylan

Resolution: duplicate
Status: newclosed

duplicate of #6490.

Note: See TracTickets for help on using tickets.