Opened 11 years ago

Closed 11 years ago

#7065 closed defect (fixed)

Regression: Grid no longer works with Datastores that do not implement Identity.

Reported by: Jared Jurkiewicz Owned by: Bryan Forbes
Priority: blocker Milestone: 1.2
Component: DojoX Grid Version: 1.1.1
Keywords: Cc:
Blocked By: Blocking:

Description (last modified by Jared Jurkiewicz)

Regression: Grid no longer works with Datastores that do not implement Identity.

In the current 1.2 version of the grid, a severe regression of functionality has occurred. Datastores that do not implement identity no longer work in it. There was specific work done in the original grid so that it would work with such stores. Now it no longer does.

This needs to be fixed.

Change History (2)

comment:1 Changed 11 years ago by Jared Jurkiewicz

Description: modified (diff)

comment:2 Changed 11 years ago by Bryan Forbes

Resolution: fixed
Status: newclosed

(In [14196]) fixes #7065 !strict

  • Changed DataGrid? to make dojo.data.api.Identity optional (only required for editing).
  • Updated multi-store test.
Note: See TracTickets for help on using tickets.