Opened 11 years ago

Closed 11 years ago

#7059 closed defect (fixed)

Text highlight/selection in Grid

Reported by: benschell Owned by: Nathan Toone
Priority: high Milestone: 1.3
Component: DojoX Grid Version: 1.1.1
Keywords: Cc:
Blocked By: Blocking:

Description

From a colleague:

If user wants to copy text of grid cells, text selection (drag or Ctrl+A) within the grid is not possible. This is killing the usability in our application.

Will there be support for selecting the text inside of a grid? Is this simply a limitation? Obviously dojox.* projects aren't held to the same standards with regards to accessibility and whatnot, but shouldn't one be able to at least copy the text out of an individual cell?

Change History (8)

comment:1 Changed 11 years ago by Nathan Toone

Milestone: future

comment:2 Changed 11 years ago by Nathan Toone

Owner: changed from Bryan Forbes to Nathan Toone

Reassigning to me

comment:3 Changed 11 years ago by Nathan Toone

Milestone: future1.3

comment:4 Changed 11 years ago by Nathan Toone

Priority: normalhigh
severity: normalmajor

comment:5 Changed 11 years ago by DS

I wanted to inquire if root cause was identified, or if this is still pending investigation.

comment:6 Changed 11 years ago by romankuzmik

The text selection is disabled explicitly in Drug And Drop CSS. By default all DND enabled wigets get '-moz-user-select' style settled into 'none'. This is due to number of issues (#6345, #4854, #6350).

You can do the following to enable system text selection for the CELL/ROW:

grid.domNode.cssText = null; dojo.style(grid.domNode, "-moz-user-select", "text"); dojo.style(grid.domNode, "MozUserSelect?", "text");

Unfortunately there is no way at all to select more than one row at ones due to architectural decision about how grid table is rendered. (grid uses set of DIVs for each row and then plain HTML table for row data and not for the entire grid data)

comment:7 in reply to:  6 Changed 11 years ago by romankuzmik

Replying to romankuzmik:

actually 'dojo.setSelectable('yourGridId', true);' is enough

comment:8 Changed 11 years ago by Nathan Toone

Resolution: fixed
Status: newclosed

(In [16331]) Fixes #7059 - add in a selectable option (default false - current behavior) that will make the text within the grid selectable. !strict

Note: See TracTickets for help on using tickets.