Opened 11 years ago

Closed 11 years ago

Last modified 9 years ago

#7041 closed defect (fixed)

dojo.date.locale.getNames regression

Reported by: Adam Peller Owned by: Adam Peller
Priority: high Milestone: 1.5.1
Component: Date Version: 1.1.1
Keywords: Cc:
Blocked By: Blocking:

Description

#6813 raised a bug in the mechanism to have "stand-alone" names (e.g. Month names) fall back to "format" names when there is no locale-specific definition for stand-alone. Some locales provide different resources, but most don't. The CLDR uses aliases to implement this, but we have to hard-code the logic.

Change History (9)

comment:1 Changed 11 years ago by Adam Peller

Resolution: fixed
Status: newclosed

(In [14130]) Fix regression caused by [14023] so month names show up in dijit._Calendar again. Fixes #7041

comment:2 Changed 11 years ago by Adam Peller

(In [14131]) Complete the comment. Refs #7041

comment:3 Changed 11 years ago by Adam Peller

Resolution: fixed
Status: closedreopened

see #7060

comment:4 Changed 11 years ago by Adam Peller

(In [14191]) Redo logic to fake aliases. [14130] failed in a build. Refs #7041

comment:5 Changed 11 years ago by Adam Peller

Resolution: fixed
Status: reopenedclosed

comment:6 Changed 9 years ago by Adam Peller

(In [22611]) Refs #7041 Apply [14191] to dojox.date objects to resolve missing standAlone month names in builds

comment:7 Changed 9 years ago by Adam Peller

(In [22661]) Refs #7041 Missed leap year reference

comment:8 Changed 9 years ago by Adam Peller

(In [22694]) Backport [22611] and [22661] to 1.5 branch. Refs #7041

comment:9 Changed 9 years ago by Adam Peller

Milestone: 1.21.5.1
Note: See TracTickets for help on using tickets.