Opened 11 years ago

Closed 11 years ago

#7036 closed defect (fixed)

dijit.scrollIntoView bug in absolute positioned div in FF3

Reported by: liucougar Owned by: Douglas Hays
Priority: high Milestone: 1.2
Component: Dijit Version: 1.1.1
Keywords: Cc:
Blocked By: Blocking:

Description

place the test case under dijit/tests/_base and load it, scroll the div so that the clickme is in the middle of the div, click on it in FF3, it scrolls to the bottom of the div, while it should not move at all (FF2 does it properly)

this is a regression introduced in r14101

Attachments (1)

test_scroll.html (639 bytes) - added by liucougar 11 years ago.

Download all attachments as: .zip

Change History (5)

Changed 11 years ago by liucougar

Attachment: test_scroll.html added

comment:1 Changed 11 years ago by liucougar

Summary: dijit.scrollIntoView bug in absoluted positioned div in FF3dijit.scrollIntoView bug in absolute positioned div in FF3

comment:2 Changed 11 years ago by liucougar

the issue is caused by "short-circuit to native if possible" for FF3, if removing FF3 from the short-circuit branch, it works fine

comment:3 Changed 11 years ago by Douglas Hays

Owner: set to Douglas Hays
Status: newassigned

comment:4 Changed 11 years ago by Douglas Hays

Resolution: fixed
Status: assignedclosed

(In [14124]) Fixes #7036. Removed FF3 short-circuit to native which is more broken than first thought. Added position:absolute tests.

Note: See TracTickets for help on using tickets.