Opened 11 years ago

Closed 7 years ago

#7020 closed defect (fixed)

Regression in dijit.form.CurrencyTextBox.constraints API docs

Reported by: Adam Peller Owned by: Neil Roberts
Priority: blocker Milestone: 1.8
Component: Doc parser Version: 1.1.1
Keywords: Cc:
Blocked By: Blocking:

Description (last modified by Adam Peller)

http://api.dojotoolkit.org/jsdoc/dijit/HEAD/dijit.form.CurrencyTextBox.constraints doesn't show the contents of the mixed-in properties. I think this was working a month or two ago.

Change History (10)

comment:1 Changed 11 years ago by Adam Peller

Description: modified (diff)

comment:2 Changed 11 years ago by Adam Peller

bah, I was sure we had this working, but the source definitely doesn't look right. I'll keep this, for now.

comment:3 Changed 11 years ago by Adam Peller

(In [14089]) Try to fix up docs for .constraints Refs #7020

comment:4 Changed 11 years ago by Adam Peller

(In [14090]) It might work better if I spell the class correctly. Refs #7020

comment:5 Changed 11 years ago by bill

Milestone: 1.2future

Moving these to future as per meeting; Neil, when you are ready to work on these you can assign a milestone.

comment:6 Changed 10 years ago by Neil Roberts

Status: newassigned

comment:7 Changed 10 years ago by Adam Peller

Priority: normalhighest
severity: normalmajor

comment:8 Changed 10 years ago by Adam Peller

(In [20118]) Try to fix constraints api doc. Refs #7020, #9904 !strict

comment:9 Changed 10 years ago by Adam Peller

(In [20129]) make api doc section contiguous. Refs #7020

comment:10 Changed 7 years ago by bill

Milestone: future1.8
Resolution: fixed
Status: assignedclosed

Looks like it's working now (http://dojotoolkit.org/api/1.8/dijit/form/CurrencyTextBox).

Note that constraints is currently specified as a local variable:

/*=====
var __Constraints = declare([NumberTextBox.__Constraints, currency.__FormatOptions, currency.__ParseOptions], {
	// summary:
	//		Specifies both the rules on valid/invalid values (minimum, maximum,
	//		number of required decimal places), and also formatting options for
	//		displaying the value when the field is not focused (currency symbol,
	//		etc.)
	// description:
	//		Follows the pattern of `dijit/form/NumberTextBox.__Constraints`.
	//		In general developers won't need to set this parameter
	// example:
	//		To ensure that the user types in the cents (for example, 1.00 instead of just 1):
	//	|		{fractional:true}
});
=====*/

If it were specified as an export from the module it would get it's own page in the API doc, like http://dojotoolkit.org/api/1.8/dijit/form/NumberTextBox.__Constraints. Perhaps that would be better.

Note: See TracTickets for help on using tickets.