Opened 12 years ago

Closed 12 years ago

#6891 closed defect (duplicate)

dojo.addOnUnload doesn't fire as expected in IE.

Reported by: smith@… Owned by: James Burke
Priority: high Milestone: 1.2
Component: General Version: 1.1.1
Keywords: dojo.addOnUnload Cc:
Blocked By: Blocking:

Description (last modified by bill)

in the startup() of my dijit, I do

dojo.addOnload(this, method)
dojo.addOnUnload(this, method);

the onloads work great. The onunload works great in Firefox. In IE, the onunload only fires when I explicitly hit "reload / refresh" (f5) and not when I use links to navigate on this page. I had to get around this by doing a dojo.connect in the main addOnload in the page, connecting window, onunload to my function. Any clues?

Change History (2)

comment:1 Changed 12 years ago by bill

Cc: smith@… removed
Description: modified (diff)
Milestone: 1.2
Owner: changed from anonymous to James Burke
Reporter: changed from guest to smith@…

I expect this is already fixed by [13555].

comment:2 Changed 12 years ago by James Burke

Resolution: duplicate
Status: newclosed

Yes, it should be fixed in [13555]. If the reporter wants to try a nightly build, they can confirm if they like: http://archive.dojotoolkit.org/nightly/

Marking this as a duplicate of #3242.

Note: See TracTickets for help on using tickets.