Opened 12 years ago

Closed 12 years ago

Last modified 10 years ago

#6830 closed defect (invalid)

dojo.query can't find Editor Widgets on Dom Node

Reported by: guest Owned by: anonymous
Priority: high Milestone: 1.2
Component: Query Version: 1.1.1
Keywords: Editor query Cc:
Blocked By: Blocking:

Description

Hi I am trying to integrate Dojo to our framework , I am handling now life cycle of Widgets , everything works O.K. besides Editor Widget. When Trying to re-render part of the Dom , first I need to destroy the Widgets there , I used ContentPane? code to destroy Widgets on some DOM Node. When the Dom Node contains Editor Widget it doesn't work , the reason for it is that the dojo.query can't find Editor Widget in DOM Node. I am attaching file with Test

Attachments (2)

test_EditorFail.html (2.5 KB) - added by guest 12 years ago.
test_EditorWork.html (2.5 KB) - added by bill 12 years ago.
modified testcase w/out substring()... it works for me

Download all attachments as: .zip

Change History (6)

Changed 12 years ago by guest

Attachment: test_EditorFail.html added

comment:1 Changed 12 years ago by bill

Why are you doing widget.id.substring(7)? The widget's id is widget.id, there's no reason for substring().

comment:2 Changed 12 years ago by bill

Resolution: invalid
Status: newclosed

I tried this w/out the strange substring() code (I guess you are trying to get rid of the dijit_ but that doesn't really make sense), and this works for me. Attaching modified test case.

Changed 12 years ago by bill

Attachment: test_EditorWork.html added

modified testcase w/out substring()... it works for me

comment:3 Changed 12 years ago by guest

Thanks for the Notes , I also tried it in my Large Application , yet the Editor is still not on the list returned by dojo,query I'll try to reproduce it again on the Test , else I will just parse the Widgets one by one and destroy any previous widget I would like to create.

comment:4 Changed 10 years ago by bill

Component: CoreQuery
Note: See TracTickets for help on using tickets.