Opened 13 years ago

Closed 13 years ago

Last modified 12 years ago

#681 closed defect (wontfix)

can't add my own attribute to a treeNode

Reported by: anonymous Owned by: anonymous
Priority: high Milestone:
Component: Widgets Version: 0.3
Keywords: tree node attribute Cc:
Blocked By: Blocking:

Description

When I create a treeNode, I try to add an attribute just like this:

<div dojoType="TreeNode?" title="blablabla" id="actualNodeId" myAttribute="bliblibli"> </div>

I then try to get the content of that particular attribute:

var title1 = dojo.widget.getWidgetById("actualNodeId").title;

var title2 = dojo.widget.getWidgetById("actualNodeId").myAttribute;

the title1 contains "blablabla" but the title2 is NOT what I am supposed to get.

What should I do? I really need to be able to do this.

Change History (2)

comment:1 Changed 13 years ago by alex

Resolution: wontfix
Status: newclosed

the value is available in dojo.widget.byId("nodeId").extraArgs.myAttribute;

This is not a bug.

comment:2 Changed 12 years ago by (none)

Milestone: 0.3release

Milestone 0.3release deleted

Note: See TracTickets for help on using tickets.