Opened 12 years ago

Closed 12 years ago

#6799 closed defect (wontfix)

dojo.coords(): wrong x/y when ancestor has border and style.overflow != visible (FF2)

Reported by: bill Owned by: sjmiles
Priority: high Milestone:
Component: HTML Version: 1.1.0
Keywords: Cc:
Blocked By: Blocking:

Description

See attached test case. On FF2, dojo.coords(node) returns the wrong result if the node's parent (or probably any ancestor) has a border, and visibility=="hidden", "auto", or "scroll". The border's width is not taken into account.

This causes drop downs to position incorrectly, see #6787.

Since the bug is only with FF2 (it's a FF bug, not a bug in our code), I think we can mark this as won't fix, but leaving here for a record (and in case some one wants to fix it).

Attachments (2)

coords.html (1.2 KB) - added by bill 12 years ago.
test case for dojo.coords() bug (put in dijit/tests/layout)
getBoxObjectFor.html (1.2 KB) - added by bill 12 years ago.
test case for underlying FF2 bug

Download all attachments as: .zip

Change History (3)

Changed 12 years ago by bill

Attachment: coords.html added

test case for dojo.coords() bug (put in dijit/tests/layout)

Changed 12 years ago by bill

Attachment: getBoxObjectFor.html added

test case for underlying FF2 bug

comment:1 Changed 12 years ago by bill

Resolution: wontfix
Status: newclosed
Note: See TracTickets for help on using tickets.