Opened 11 years ago

Closed 11 years ago

Last modified 8 years ago

#6787 closed defect (wontfix)

ComboBox: popup appears at wrong offset (FF2)

Reported by: Adam Peller Owned by: bill
Priority: high Milestone: 1.2
Component: Dijit - Form Version: 1.1.0
Keywords: Cc:
Blocked By: Blocking:

Description

It feels like this is a regression of a bug that was reported in trac long ago... I'll keep looking for it.

Load layout/test_BorderContainer.html and scroll down to the second example. Click the dropdown for 'foo' in the ComboBox?. Note that the ComboBox? popup appears above and to the left of where it should be and covers the input control

Attachments (5)

ie.png (20.3 KB) - added by bill 11 years ago.
works for me
ff2.png (5.1 KB) - added by bill 11 years ago.
pos.html (1.8 KB) - added by bill 11 years ago.
simpler testcase, put in same directory as test_BorderContainer.html
pos2.html (1.2 KB) - added by bill 11 years ago.
testcase of dojo._abs() (not working on FF2)
getBoxObjectFor.html (1.2 KB) - added by bill 11 years ago.
root FF2 bug

Download all attachments as: .zip

Change History (12)

comment:1 Changed 11 years ago by bill

Owner: changed from bill to Adam Peller

It's working fine for me:

works for me

Changed 11 years ago by bill

Attachment: ie.png added

works for me

comment:2 Changed 11 years ago by Adam Peller

Owner: changed from Adam Peller to bill
Summary: IE: ComboBox popup appears at wrong offsetIE6: ComboBox popup appears at wrong offset

Oops, my bad. IE6 only.

comment:3 Changed 11 years ago by bill

Owner: changed from bill to Adam Peller

But I tested it on IE6, see the screenshot above. It's working fine.

comment:4 Changed 11 years ago by Adam Peller

Summary: IE6: ComboBox popup appears at wrong offsetFF2: ComboBox popup appears at wrong offset

ugh. FF2. Knew it was some browser I don't use everyday.

Changed 11 years ago by bill

Attachment: ff2.png added

comment:5 Changed 11 years ago by bill

Owner: changed from Adam Peller to bill
Status: newassigned
Summary: FF2: ComboBox popup appears at wrong offsetComboBox: popup appears at wrong offset (FF2)

Oh I see.... ok I'll take a look at this. Seems like a problem with dojo._abs(), or rather a bug in FF that dojo._abs() needs to work around. I made a smaller test case, which I'll attach. Looks like this:

Changed 11 years ago by bill

Attachment: pos.html added

simpler testcase, put in same directory as test_BorderContainer.html

Changed 11 years ago by bill

Attachment: pos2.html added

testcase of dojo._abs() (not working on FF2)

Changed 11 years ago by bill

Attachment: getBoxObjectFor.html added

root FF2 bug

comment:6 Changed 11 years ago by bill

Resolution: wontfix
Status: assignedclosed

Talked to Adam about this and decided to mark this as wontfix... the problem is unfortunate but isn't catastrophic unless you have large borders.

I filed #6799 about the root bug in dojo.coords().

comment:7 Changed 8 years ago by bill

Component: DijitDijit - Form
Note: See TracTickets for help on using tickets.