Opened 11 years ago

Closed 10 years ago

Last modified 8 years ago

#6783 closed defect (duplicate)

Incorrect values of checkboxes when dnd-ing rows with IE

Reported by: corentin.duperray+dojo@… Owned by: Douglas Hays
Priority: high Milestone: 1.3
Component: Dijit - Form Version: 1.1.0
Keywords: dnd ie checkbox rows value Cc:
Blocked By: Blocking:

Description

Hello. My problem doesn't appear in Firefox, just with IE.

I want to reorder rows in a table, and these rows contain checkboxes. The problem is that when I drag&drop the rows, values of the dragged checkbox is reset to False,whatever is the real value of the checkbox. (as i can see in the console) If i just check or uncheck the box without dragging it, there is no problem.

Attachments (2)

minimal_code.jsp (2.5 KB) - added by guest 11 years ago.
6783.html (1.8 KB) - added by Douglas Hays 10 years ago.
testcase showing failure in dojo 1.2.3

Download all attachments as: .zip

Change History (8)

Changed 11 years ago by guest

Attachment: minimal_code.jsp added

comment:1 Changed 11 years ago by bill

Cc: corentin.duperray+dojo@… removed
Component: GeneralDijit
Milestone: 1.3
Owner: anonymous deleted
Reporter: changed from guest to corentin.duperray+dojo@…

That's a strange one... not sure where the problem is, with DnD or the Checkbox widget (does dragging a native checkbox have the same problem?)

comment:2 Changed 11 years ago by bill

Milestone: 1.31.4

bumping 1.4 tickets to 1.5, and most 1.3 tickets to 1.4

comment:3 Changed 11 years ago by bill

Can you give a valid test case? The test case you gave has many syntax errors, such as:

  1. no <head> or <html> tags
  2. <tr> and <td> tags without a <table> tag
  3. stuff after the closing </body> tag
  4. the enreg() function doesn't make sense as you are trying to subtract two values that aren't numbers:
dijit.byId("myNotes") -
dojo.query("[name^=cb]").forEach("alert(item.checked);");

comment:4 Changed 10 years ago by Douglas Hays

Owner: set to Douglas Hays

Changed 10 years ago by Douglas Hays

Attachment: 6783.html added

testcase showing failure in dojo 1.2.3

comment:5 Changed 10 years ago by Douglas Hays

Milestone: 1.41.3
Resolution: duplicate
Status: newclosed

Dup of #8666. Fixed in [16718] in Dojo 1.3.

comment:6 Changed 8 years ago by bill

Component: DijitDijit - Form
Note: See TracTickets for help on using tickets.