Opened 11 years ago

Closed 11 years ago

#6755 closed defect (fixed)

set dojo.css base font size to 12px

Reported by: alex Owned by: alex
Priority: high Milestone: 1.2
Component: Core Version: 1.1.0
Keywords: Cc:
Blocked By: Blocking:

Description

as discussed in weekly full team meeting for 05/07/08

Change History (10)

comment:1 Changed 11 years ago by alex

Resolution: fixed
Status: newclosed

(In [13736]) updating the overall font size to be 12px as discussed in the weekly full-team meeting. Fixes #6755

comment:2 Changed 11 years ago by bill

Resolution: fixed
Status: closedreopened

Not quite, you affected the font-size for FF and Safari but not for IE. IE is still presumably 13px. Maybe can do font-size: 88% or something like that (but need to test that ctrl-+ and ctrl-- still work in that case).

comment:3 Changed 11 years ago by alex

(In [13744]) updates for IE 6. Refs #6755

comment:4 Changed 11 years ago by bill

No, IE6's (and probably IE7's) font size is still small, i.e. 13px. Needs to be 12px to match change to FF/Safari.

comment:5 Changed 11 years ago by nonken

Resolution: fixed
Status: reopenedclosed

(In [14525]) fixed font-size for ie6/7, fixes #6755

comment:6 Changed 11 years ago by bill

(In [14527]) For better testing how dojo default font appears; refs #6755.

comment:7 Changed 11 years ago by bill

(In [14528]) Fix comment; refs #6755.

comment:8 Changed 11 years ago by bill

Resolution: fixed
Status: closedreopened

Reopening this because on IE, [14525] messes up not only Editor (see #7636) but also any frames/iframes.

Setting font-size to 12px seems to be not so easy.

comment:9 Changed 11 years ago by bill

Oops, above comment was inaccurate.... regular frames/iframes appear to be fine... the problem is just for editor because in _getIframeDocTxt() it gets the computed style of the srcNodeRef and copies it to the iframe document. Except that it isn't really a computed style since the font-size is 75% rather than a px value.

comment:10 Changed 11 years ago by bill

Resolution: fixed
Status: reopenedclosed

(In [15229]) Don't set font on both html and body because if font-size is a percentage (ex: 75%), the effect is compounded and the text becomes really small.

Fixes #6755, #7636 !strict

Note: See TracTickets for help on using tickets.