Opened 14 years ago

Closed 14 years ago

Last modified 13 years ago

#674 closed defect (duplicate)

IFrameIO transport : data is undefined for text/plain mimetime

Reported by: Jonathan Aquino Owned by: James Burke
Priority: high Milestone:
Component: General Version: 0.2
Keywords: Cc:
Blocked By: Blocking:

Description

When I use the IFrameIO transport, in the load() callback, data is undefined. I am using the following workaround to get at the data:

data = dojo.io.iframeContentWindow(dojo.io.IframeTransport?.iframe).document.body.innerHTML; if (data.match(/<pre>(.*)</pre>/i)) {

Internet Explorer [Jon Aquino 2006-05-06] data = RegExp?.$1;

}

You might want to use the same technique in IFrameIO.js instead of "value = ifw.innerHTML" which returns undefined. Hopefully this solution is not brittle.

Tested in Firefox 1.5.0.3 and IE 6.0. Not tested in Safari, Opera and other browsers. Actually I'm not even sure if IFrameIO works at all in Safari--see ticket 672.

Change History (4)

comment:1 Changed 14 years ago by anonymous

dang, the code formatting got mucked up. Here it is again:

data = dojo.io.iframeContentWindow(dojo.io.IframeTransport.iframe).document.body.innerHTML;
if (data.match(/<pre>(.*)</pre>/i)) {
    // Internet Explorer [Jon Aquino 2006-05-06]
    data = RegExp.$1;
}

comment:2 Changed 14 years ago by James Burke

Milestone: 0.3.1
Owner: changed from anonymous to James Burke
Status: newassigned

comment:3 Changed 14 years ago by James Burke

Resolution: duplicate
Status: assignedclosed

Closing as a dupe of #131.

comment:4 Changed 13 years ago by (none)

Milestone: 0.3.1

Milestone 0.3.1 deleted

Note: See TracTickets for help on using tickets.