Opened 11 years ago

Closed 11 years ago

#6733 closed defect (wontfix)

Editor: can only enter a single char on last line (Safari 3.1/mac)

Reported by: bill Owned by: liucougar
Priority: high Milestone: 1.2
Component: Editor Version: 1.1.0
Keywords: Cc:
Blocked By: Blocking:

Description

Regression since Editor refactor.

  1. Load mail.html on safari 3.1/mac.
  2. Click "New Message button"
  3. make sure caret is at end of last line, and hit return.
  4. hit "a" key multiple times. only one "a" appears

Maybe same cause as #6324 but obviously not the same bug since it's a different widget.

This is happening on safari 4525.18, and not happening for Joose on 4525.13. Hopefully it's not another of those bugs that only happens for me, but perhaps it is.

Attachments (1)

stuck.png (11.0 KB) - added by bill 11 years ago.

Download all attachments as: .zip

Change History (2)

Changed 11 years ago by bill

Attachment: stuck.png added

comment:1 Changed 11 years ago by bill

Resolution: wontfix
Status: newclosed

I figured out why this only happens for me. I'm running MacOS English but with the Japanese IME. When it's set to "romaji" rather than "U.S." the problem happens. "Romaji" and "U.S." are essentially the same setting (except that the former causes this bug :-( ).

I just asked someone to try a Japanese OS and this doesn't reproduce for them either; I guess it's a really esoteric bug that we shouldn't bother fixing.

Note: See TracTickets for help on using tickets.