Opened 11 years ago

Closed 11 years ago

#6705 closed defect (fixed)

shape.moveToBack() makes the shape unselectable

Reported by: guest Owned by: Eugene Lazutkin
Priority: high Milestone: 1.3
Component: DojoX GFX Version: 1.1.0
Keywords: Cc:
Blocked By: Blocking:

Description

To summarize my report:

  • Version of Dojo and build name:

nightly build version 13621 and previous versions

  • Browser versions and platforms where the bug occurs:

both firefox and IE, windows and mac

  • Error messages displayed (if any):
  • A contact address so we can follow-up with you:

gyang2007@…

  • Describe the exact situation in which the bug occurs as precisely as possible. Is it reproducible? Did it break in a certain release? Is it still an issue with nightly or subversion head? etc.

Click the rectangle or round rectangle image using left mouse button, then click the drawing surface, which is "onmousedown" event, draw either shape. Or click the shapes on the screen, hold the mouse, then press either 'B' or 'b' key, release the mouse. The shape becomes unelectable after the mouse is released. Do the same operation for moveToFront() by pressing 'F' or 'f', release the mouse, the shape is still selectable.

  • Testcases and patchces are even better.

I reproduced the bug based on dojox.sketch: http://www.intrinsyx.com/sharon/moveToBackBug/moveToBackBug.html

The 1.0.0 or 1.1.0 version hosted at dolcdn generated some errors for jframe, so the nightly build version was used with the example. The source code(48k) is attached (without dojo).

Attachments (1)

moveToBackBug.zip (47.1 KB) - added by guest 11 years ago.

Download all attachments as: .zip

Change History (4)

Changed 11 years ago by guest

Attachment: moveToBackBug.zip added

comment:1 Changed 11 years ago by Eugene Lazutkin

Milestone: 1.2
Priority: highnormal
severity: majornormal
Status: newassigned
Summary: shape.moveToBack() makse the shape unselectableshape.moveToBack() makes the shape unselectable

All selection is done be the underlying SVG/VML. Most probably the problem lies with browsers, and cannot be fixed easily on our side. But I'll investigate.

comment:2 Changed 11 years ago by Eugene Lazutkin

Milestone: 1.2future

Moving all open ticketd to the future.

comment:3 Changed 11 years ago by Eugene Lazutkin

Milestone: future1.3
Resolution: fixed
Status: assignedclosed

It looks like it was a problem for the VML renderer. It was fixed in #7339.

Note: See TracTickets for help on using tickets.