Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#6674 closed defect (worksforme)

Dialog: moving scrollbar *on the dialog* recenters it

Reported by: bill Owned by: dante
Priority: high Milestone: 1.2
Component: DojoX Widgets Version: 1.1.0
Keywords: Cc:
Blocked By: Blocking:

Description

In the dojox dialog, there's a test/demo where the dialog itself has a scrollbar. If you drag the dialog somewhere and then move the scrollbar, the dialog will suddenly recenter itself in the viewport.

Didn't try on dijit.Dialog since the test files don't have scrollbars.

PS: There was a big philosophical discussion about what events should/shouldn't recenter a dialog (after the user has dragged it), but this is unrelated to that.

Attachments (1)

test_Dialog.html (4.8 KB) - added by bill 12 years ago.
simple testcase is working

Download all attachments as: .zip

Change History (5)

comment:1 Changed 12 years ago by dante

Milestone: 1.2

comment:1 Changed 12 years ago by dante

Status: newassigned

comment:2 Changed 12 years ago by dante

Resolution: worksforme
Status: assignedclosed

i can't reproduce this, except for when you scroll inside the dialog (with a scrollbar) to the bottom, the window continues to scroll, which is the expected behavior imho. I can't reproduce the "recenter" on scroll problem at all. please reopen w/ more precise reproduction.

comment:3 Changed 12 years ago by bill

Yeah, I don't know, I can't reproduce it but also I don't know where the test file is that you originally showed me; it's not checked into SVN apparently.

Changed 12 years ago by bill

Attachment: test_Dialog.html added

simple testcase is working

Note: See TracTickets for help on using tickets.