Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#6673 closed defect (fixed)

Tree Critical Problem. Tree nodes dissapear

Reported by: guest Owned by: bill
Priority: blocker Milestone:
Component: Dijit Version: 1.1.0
Keywords: Cc:
Blocked By: Blocking:

Description

When opening and closing the tree an expandable node in 1/5/2008 nighltly build the tree node branch dissapear. I is possible to dissapear all the tree from the root node.

See: /js/ajax/dijit/tests/tree/test_Tree_Programmatic.html

Tested on FF2 , only very easy to replicate.

thanks

Eduardo

Change History (4)

comment:1 Changed 11 years ago by dante

i verified the test breaks, and in a fit of fear reverted my most recent changes to Tree and tested again. It still fails, so I think i'm in the clear. On collapse the node is being wiped out completely.

comment:2 Changed 11 years ago by bill

Owner: set to bill
Status: newassigned

I'll take ownership of this, at least temporarily until I trace down where the problem is.

comment:3 Changed 11 years ago by bill

Resolution: fixed
Status: assignedclosed

(In [13537]) Fix bug where closing a tree node would hide the node itself rather than just it's children; regression from [13521].

TreeNode? is unusual in that it defines containerNode lazily, so the code in _Container to set containerNode automatically was actually messing things up.

Fixes #6673, refs #6604. !strict

comment:4 Changed 11 years ago by bill

(In [13568]) Avoid null reference. Refs #6673, #6604. !strict

Note: See TracTickets for help on using tickets.