Opened 14 years ago

Closed 13 years ago

Last modified 12 years ago

#667 closed enhancement (invalid)

dojo publish and subscribe functions

Reported by: rakesh Owned by: alex
Priority: high Milestone:
Component: Core Version: 0.2
Keywords: Cc:
Blocked By: Blocking:

Description

dojo subscribe function(dojo.event.subscribe) doesn't seem to work after page onLoad event. Any subscribers created after page onload event donot receive any published events.

Similarly dojo publish function(dojo.event.publish) doesn't seem to publish any event prior to the page onLoad event.

Change History (5)

comment:1 Changed 14 years ago by bill

Cc: alex added
Component: GeneralCore
Milestone: 0.3.1

Hmm, if this is broken it seems like a pretty bad bug. Alex, passing to you (you can postpone to 0.4 if you want to, but we should mark the milestone as either 0.3.1 or 0.4)

comment:2 Changed 14 years ago by bill

Cc: alex removed
Owner: changed from anonymous to alex

comment:3 Changed 13 years ago by alex

Priority: normalhigh
Status: newassigned

comment:4 Changed 13 years ago by alex

Resolution: invalid
Status: assignedclosed

Unfortunately I'm not able to reproduce this. I'm updating the tests/widget/event/test_topic.html

I'm marking invalid for now, but I'm not entirely willing to discount either the likelyhood or severity of this bug. I just don't have a test case that reproduces it.

comment:5 Changed 12 years ago by (none)

Milestone: 0.3.1

Milestone 0.3.1 deleted

Note: See TracTickets for help on using tickets.