Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#6664 closed defect (fixed)

dijit test pages are misleading regarding styling and themes

Reported by: alex Owned by: dante
Priority: high Milestone: 1.2
Component: Dijit Version: 1.1.0
Keywords: dijit, tests Cc: Sam Foster, dante, phiggins, edencardim@…
Blocked By: Blocking:

Description

the structure of Dijit test-pages doesn't make it clear that users need to add the theme class explicitly on the body of their document, nor does it make clear that you must pull in the css files for the themes you wish to use.

Many users still use the test files as examples of how to set up their pages, and making this clearer would reduce the number of support requests we need to answer. The right solution, I think, is to pull in tundra by default and have the helper pull in an alternate and change the body style instead of having the helper be responsible for the initial application of both.

Change History (18)

comment:1 Changed 11 years ago by alex

Cc: edencardim@… added

comment:2 Changed 11 years ago by bill

This has bothered me a long time too, mainly for the reason you mentioned but also because it exacerbates race conditions loading CSS (where the JS starts executing before the CSS has finished loading and bad things happen). If that's doable then let's do it (although I'm not volunteering to modify all the test files myself).

comment:3 Changed 11 years ago by dante

Owner: set to dante
Status: newassigned

comment:4 Changed 11 years ago by dante

(In [13661]) refs #6664 - all "public" dijit tests using _testCommon now use tundra as the default theme. WARNING: this currently breaks tests in nihilo / soria where there is a dijit.byId('something') in an addOnLoad because we're stalling parsing (not in the tundra case ... ) by a few ms. we probably don't need to, but we're fighting an inconsistant css race condition.

need to do dijit/demos, and dojox/* still ... that's next. please svn up dijit/ and check for any regressions based on this checkin. I've tested in ie6, ff2 and safari _most_ every test, but it is admittedly a little overwhelming so extra eyes would be appreciated.

comment:5 Changed 11 years ago by dante

(In [13662]) refs #6664 - missed tree innard tests, and removes duplicated styles from matrix.

comment:6 Changed 11 years ago by dante

(In [13663]) refs #6664 - hit all the demos.

comment:7 Changed 11 years ago by dante

(In [13665]) refs #6664 - hit dojox test files using _testCommon.

comment:8 Changed 11 years ago by dante

Resolution: fixed
Status: assignedclosed

(In [13666]) fixes #6664 - hit every test in dijit and dojox. please reopen if I missed something. I will fix immediately.

comment:9 Changed 11 years ago by dante

Resolution: fixed
Status: closedreopened

I forgot dojox/grid/* ...

comment:10 Changed 11 years ago by dante

Resolution: fixed
Status: reopenedclosed

(In [13680]) re fixes #6664 - grid was the last little piece to get.

comment:11 Changed 11 years ago by dante

(In [13694]) refs #6664 - i knew the delayed parsing in the nihilo / soria case would break something. the jist is: when using nihilo / soria, parsing is stalled by 120ms, though it may not have to be. This doesn't affect tundra at all, as no magic is happening there. fixes #6732

comment:12 Changed 11 years ago by dante

(In [13697]) refs #6664 - accidentally copied the wrong "default dojo.js line" for root dijit tests. tests needing extra locales should be in i18n/ folder. (for clarity)

comment:13 Changed 11 years ago by Adam Peller

(In [13700]) Move Calendar tests using non-default locales to tests/i18n. Refs #6664

comment:14 Changed 11 years ago by bill

(In [13778]) Remove duplicate import. Refs #6664.

comment:15 Changed 11 years ago by bill

(In [13944]) <link ... /> is invalid, should be <link ... > (unless you are writing XHTML). Refs #6664, #6887.

comment:16 Changed 11 years ago by bill

(In [14047]) Make test_TabContainer?theme=soria work. Refs #6664.

comment:17 Changed 11 years ago by Adam Peller

(In [14117]) Put back djConfig.extraLocale definition, since there is a test which explicitly runs in de-de locale. Thanks, Bill, for noticing. Refs #6664

comment:18 Changed 11 years ago by Adam Peller

(In [14190]) Load locales used in this test in the bootstrap, removed in [13661]. Refs #6664

Note: See TracTickets for help on using tickets.