Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#6649 closed task (fixed)

DropDownButton/ComboButton/ToggleButton: disabled state looks incorrect

Reported by: bill Owned by: bill
Priority: high Milestone: 1.2
Component: Dijit - LnF Version: 1.1.0
Keywords: Cc:
Blocked By: Blocking:

Description

Problems with style for disabled buttons:

  • disabled DropDownButton and ComboButton should have a gray arrow not a black arrow
  • text on ComboButton should be grayed out but isn't
  • disabled but checked ToggleButton should have a gray check icon, not black

Change History (7)

comment:1 Changed 12 years ago by bill

Status: newassigned

Working on this now, including moving all the arrows to a sprite image file.

comment:2 Changed 12 years ago by bill

Resolution: fixed
Status: assignedclosed

(In [13650]) Fixes for disabled buttons:

  • gray arrow not black arrows
  • make disabled ComboButton? text gray, not black
  • don't make disabled buttons semi-transparent; if the background color of the page isn't white, it leaks through and the buttons look strange.
  • move arrow icons to a sprite image, thanks to sfoster for help on this (still some work to do on this; old images still being referenced in some places)

Fixes #6649.

comment:3 Changed 12 years ago by bill

(In [13689]) Remove old arrow image files in favor of sprite file (except for ComboBox? still using special image).

Also made sprites square rather than rectangular (arrows still the same shape, but cenetered vertically in the image files now) to make CSS easier.

Finally, fixes TitlePane? arrow direction in RTL mode.

Refs #6649.

comment:4 Changed 12 years ago by bill

(In [13690]) Fix FloatingPane? and SortList? to use tundra sprite image arrows. Since these arrows are float:right they can't be vertical-align: middle so instead using the trick of a   to make height==surrounding div height, and then vertical background-align is "center". Refs #6649.

comment:5 Changed 12 years ago by bill

(In [13691]) Remove grid's references to removed tundra arrow files. Grid has it's own version of arrows that look fine. (It would be better to reference the tundra sprite image perhaps but grid's design precludes that, since there isn't a separate <div> for the icon) Refs #6649.

comment:6 Changed 12 years ago by bill

(In [13873]) Fix high contrast mode regression showing Menu arrows from [13689]. Refs #6649. !strict

comment:7 Changed 12 years ago by bill

(In [13929]) Fix arrow direction on RTL Menu on tundra. Simplify CSS for Menus in nihilo/soria. Refs #6649.

Note: See TracTickets for help on using tickets.