Opened 12 years ago

Closed 12 years ago

#6631 closed defect (wontfix)

Combo Boxes disappear in IE 6.0 when dialog opens

Reported by: guest Owned by:
Priority: low Milestone:
Component: Dijit Version: 1.0
Keywords: Cc:
Blocked By: Blocking:

Description

Hi,

I have a multiple combo boxes (select) on my page. When I open a DOJO Dialog from this page, it grays out the background page.When the gray out happens the combo boxes on my parent page just disappear. This behaviour is seen only in IE 6.0 and can be seen in the below link also.

http://download.dojotoolkit.org/current-dev/dojo-release-1.1.0/dijit/tests/test_Dialog.html

Open this link in FF and IE, Notice the background page, there are a few combo boxes on the page which you can see grayed out in FF but not in IE.

Please let me know if DOJO has a workaround for this.

Thanks, Hrishikesh

Change History (2)

comment:1 Changed 12 years ago by bill

Priority: highlow
severity: majornormal

Yes, they do. This is by design as the lesser of two evils, although debatable. When dialog displays we gray out the whole screen, and <select> nodes can either disappear completely, or not get grayed out at all. Those are the only two options on IE6.

comment:2 Changed 12 years ago by bill

Resolution: wontfix
Status: newclosed
Note: See TracTickets for help on using tickets.