Opened 12 years ago

Closed 11 years ago

Last modified 11 years ago

#6588 closed defect (fixed)

Firebug / Firebug-lite incompatibility: Firebug-lite initializes even on Firefox

Reported by: bill Owned by: Mike Wilcox
Priority: high Milestone: 1.2
Component: General Version: 1.1.0
Keywords: Cc:
Blocked By: Blocking:

Description

Posted description here but cross-referencing into this ticket since dojo has it's own version of firebug.

===

I'm seeing a lot of crashes with the latest Firebug and Firefox and trying to trace them down now. The first red flag I noticed is that Firebug-light is initializing on Firefox. (It should only initialize on IE/safari/etc.)

See the original firebug lite (first line) or our modified version (line 61) .... it branches on:

 if (!("console" in window) || !("firebug" in console)) { 

... the problem is that console.firebug is not defined (anymore?), even though firebug is installed and running.

===

Change History (8)

comment:1 Changed 12 years ago by bill

Summary: Firebug / Firebug-lite incompatibility: Firebug initializes even on FirefoxFirebug / Firebug-lite incompatibility: Firebug-lite initializes even on Firefox

comment:2 Changed 12 years ago by bill

Resolution: fixed
Status: newclosed

OK, the newest firebug fixes this problem, so we don't need to do anything on our end.

comment:3 Changed 12 years ago by guest

Resolution: fixed
Status: closedreopened

This is occurring currently with Firebug 1.2 beta. Further discussion is here:

http://groups.google.com/group/firebug/browse_thread/thread/565df9469d4fa8e7/a7308aebc8148dab?#a7308aebc8148dab

"The console implementation in Firebug 1.2 is different from 1.1. So any code that relies on the only mechanism needs to be reviewed."

comment:4 Changed 11 years ago by dylan

Milestone: tbd
Owner: changed from anonymous to Mike Wilcox
Status: reopenednew

comment:5 Changed 11 years ago by Mike Wilcox

Resolution: fixed
Status: newclosed

(In [14337]) Fixes #6588 !strict Changed up the FB detection, based on whether the browser is FF or not. Couldn't test FB-1.1 because I couldn't download that version (getfirebug server problems).

Note, I didn't witness the problem in the ticket. It looks that FB-1.2 works with the old detection. I fixed it anyway.

Enabling Firebug Lite is different for FF3, now you disable Firebug, and Firebug Lite will install. isDebug turns it off. Backwards compatible for FF2

comment:6 Changed 11 years ago by Mike Wilcox

(In [14373]) Refs #6588 !strict Removing some stray comments

comment:7 Changed 11 years ago by Mike Wilcox

(In [14454]) Refs #6588 !strict - Added check for previous version of Firebug. Should work well now with Firebug 1 and 1.2 - 1.1 is a bad and hard to find coe base, and should probably just not be supported./nAlso did a serious of minor tweaks to make this a little more jslint friendly. A little.

comment:8 Changed 11 years ago by bill

Milestone: tbd1.2
Note: See TracTickets for help on using tickets.