Opened 12 years ago

Closed 11 years ago

#6587 closed defect (wontfix)

chart.destory() leaves labels behind.

Reported by: guest Owned by: Eugene Lazutkin
Priority: high Milestone: 1.2
Component: Charting Version: 1.1.0
Keywords: Cc: jwinton@…, bill
Blocked By: Blocking:

Description

chart.destory() call does not remove label elements.

In the attached example, click show chart, click close and click show chart again...

Under Firefox 2 you will see the chart is drawn lower and lower below the original spot.

Under IE 6 you will see the chart on the left grows taller each time.

Firefox 2.0.0.14 IE 6.0.2900.2180.xpsp_sp2_gdr.070227-2254 Dojo Nightly build for 2008-04-22 & Dojo Release 1.1.0

Attachments (1)

chartdestory.zip (2.0 KB) - added by guest 12 years ago.
example htm file

Download all attachments as: .zip

Change History (4)

Changed 12 years ago by guest

Attachment: chartdestory.zip added

example htm file

comment:1 Changed 11 years ago by dylan

Milestone: 1.2

comment:2 Changed 11 years ago by Eugene Lazutkin

It looks like its some kind of a dialog sizing artifact. Can you reproduce this effect without a dialog? It'll help to understand what's exactly the problem is.

comment:3 Changed 11 years ago by Eugene Lazutkin

Cc: jwinton@… bill added
Resolution: wontfix
Status: newclosed

The same problem was discussed in #5168 and #5779. It looks like html labels are off in dynamically sized widgets most probably because they are dynamically sized and change geometry on the fly. Simple fixes (switching to relative placement, switching to absolute placement) didn't work. There are no other ways to place html labels. If it is possible to fix it, the fix will be beyond graphics in the html realm. If you don't want to mess with html bugs, simply switch to gfx labels by adding "htmlLabels: false" to the axis parameters.

For now I am marking this ticket as wontfix --- there is no way to fix it at the moment. If somebody has a solution --- I am all ears. Just comment in this ticket and I'll get a notification automatically.

Note: See TracTickets for help on using tickets.