Opened 11 years ago

Closed 11 years ago

#6576 closed defect (invalid)

BorderContainer: In IE7, the page overflows the window when user zooms

Reported by: guest Owned by: bill
Priority: high Milestone: 1.3
Component: Dijit Version: 1.1.0
Keywords: Cc: haavikko@…
Blocked By: Blocking:

Description

For example, open the following test in IE7: dojo/dojox/grid/tests/test_grid_layout_borderContainer.html Increase text size -> the grid becomes larger than the window, and horizontal scrollbar appear on window. This is inconvenient especially if the grid already contains a horizontally scrollable view, as the user now needs to manage two scrollbars at once. On Firefox, the font size increases but grid stays nicely within the limits of the window.

This may be due to how IE zoom feature is implemented and impossible to fix.

About IE zoom feature: http://www.wilsonminer.com/posts/2007/mar/16/problem-pixels/ Quote: Text zoom increases the size of the text, whilst keeping every other dimension the same. Page zoom makes everything bigger, which can introduce horizontal scrolling (even, in my experience, on fluid width sites - try the Google home page).

Change History (4)

comment:1 Changed 11 years ago by bill

Milestone: tbd

mark all (open) tickets w/blank milestones to be "tbd"; their milestones need to be set to a version number or to "future"

comment:2 Changed 11 years ago by Bryan Forbes

Component: DojoX GridDijit
Milestone: tbd1.3
Owner: changed from sorvell to bill
Summary: In IE7, the grid overflows the window when user increases font sizeIn IE7, the page overflows the window when user increases font size

The problem here is the difference between increasing the text size and page zooming. If you increase the text size by going to View->Text Size->Larger everything works as it should. However, if you use Ctrl-+ or Ctrl-mouse wheel up, it zooms the page which is what you are seeing. This isn't grid specific as this happens in http://archive.dojotoolkit.org/nightly/dojotoolkit/dijit/tests/layout/test_BorderContainer_full.html and most other tests.

comment:3 Changed 11 years ago by bill

Summary: In IE7, the page overflows the window when user increases font sizeBorderContainer: In IE7, the page overflows the window when user zooms

Logically Ctrl-+ is shrinking the viewport (since each logical pixel has >1 physical pixels), and BorderContainer would be happy to adjust to that (the same way as if the user had resized the browser window), but the problem is that apparently getViewportSize() doesn't reflect that shrinkage.

Probably nothing can be done but I'll think about it. (One could also argue that it's working as intended by IE.)

comment:4 Changed 11 years ago by bill

Resolution: invalid
Status: newclosed

This is working as intended by Microsoft. Scrollbars should be showing up.

Note: See TracTickets for help on using tickets.