Opened 11 years ago

Closed 11 years ago

#6554 closed defect (invalid)

Bars and Clusterd Bars - min value issue

Reported by: guest Owned by: Eugene Lazutkin
Priority: high Milestone: 1.2
Component: Charting Version: 1.0
Keywords: Cc: yazad3@…
Blocked By: Blocking:

Description

Hi,

I have bumped into a strange defect... I had a chart of type "ClusteredColumns?" it works fine, but the moment I change the type fropm clustered columns to "Bars" or "ClusteredBars?" the minimum value disappears - I have attached a sample file with comments. If more than one value is the least - they all disappear, if all values are same, all the bars disappear! Please have a look at the attachment and

comment/uncomment the below mentioned three lines: chart18.addPlot("default", {type: "ClusteredBars?", gap: 2}); chart18.addPlot("default", {type: "ClusteredColumns?", gap: 2}); chart18.addPlot("default", {type: "Bars", gap: 2});

In a combination with :

chart18.addSeries("Series A",[29, 25, 27, 44, 57],{stroke: {color: "red"}, fill: "lightpink"}); chart18.addSeries("Series A", [29, 25, 25, 44, 57], {stroke: {color: "red"}, fill: "lightpink"}); chart18.addSeries("Series A",[25, 25, 25, 25, 25],{stroke: {color: "red"}, fill: "lightpink"});

I am raising this as severity/priority normal... but if there is no work around available, I request you to raise the severity/priority to whatever you feel appropriate. Thanks in advance.

Regards, Yazad Khambata yazad3@…

Attachments (1)

trac.htm (1.4 KB) - added by guest 11 years ago.

Download all attachments as: .zip

Change History (6)

Changed 11 years ago by guest

Attachment: trac.htm added

comment:1 Changed 11 years ago by guest

Please note 6553 is raised on dojo 1.1, you may merge the tickets if that helps in managing the defects.

Regards, Yazad Khambata yazad3@…

comment:2 Changed 11 years ago by Eugene Lazutkin

Milestone: 1.1.1
Status: newassigned

#6553 is the dup. Merging both tickets together.

comment:3 Changed 11 years ago by Eugene Lazutkin

Milestone: 1.1.11.2

comment:4 Changed 11 years ago by Eugene Lazutkin

Cc: yazad3@… added

comment:5 Changed 11 years ago by Eugene Lazutkin

Resolution: invalid
Status: assignedclosed

Actually it is not a bug. Selecting Bar (or StackedBar?) instead of Column (or StackedColumn?) is effectively swaps X and Y axes. If you look closer at your axes' definition you'll see that they are not symmetrical --- Y axis has "includeZero" set to true, while X axis defaults to false. That's why columns in vertical dimension are drawn from 0 to whatever their Y value is, but bars are drawn from the minimal value to whatever their X (former Y) value is. In your example the minimal value is 25. If you set "includeZero: true" in your X axis definition you will force it to start from 0 just like in case of columns.

Note: See TracTickets for help on using tickets.