Opened 12 years ago

Closed 10 years ago

#6515 closed defect (wontfix)

Tree DnD performance degrades in IE6

Reported by: guest Owned by: Eugene Lazutkin
Priority: high Milestone: future
Component: Dijit Version: 1.1.0
Keywords: Cc: bill
Blocked By: Blocking:

Description

If you drag over a tree and hit esc in IE 6 on XP, the avatar begins to lag behind the cursor the next time you drag over the tree. This is especially noticeable after a couple of cancels, when the avatar starts lagging by several seconds.

The easiest way to test this behavior is just use Test_Tree_DnD.html. On slower machines, I think a slight delay is normal when moving across tree nodes because of highlighting, etc going on. So to make the problem more evident, you can increase the size of one of the tree containers and just drag over the empty space under the tree - at first the avatar ought to follow the cursor almost perfectly, but after canceling a few drags it becomes extremely laggy. I've also tested on Firefox 2.0.0.13 on XP, which doesn't have this problem.

Change History (5)

comment:1 Changed 12 years ago by dylan

Milestone: 1.2

comment:2 Changed 11 years ago by dylan

Owner: changed from anonymous to Eugene Lazutkin

comment:3 Changed 11 years ago by Eugene Lazutkin

Cc: bill added
Component: GeneralDijit

I'll try to reproduce it with the regular DnD. But the difference between IE and FF points to gc problems.

comment:4 Changed 11 years ago by Eugene Lazutkin

Milestone: 1.2future

Moving all open ticketd to the future.

comment:5 Changed 10 years ago by bill

Resolution: wontfix
Status: newclosed
Note: See TracTickets for help on using tickets.