Opened 13 years ago

Closed 13 years ago

Last modified 12 years ago

#651 closed defect (fixed)

Context Menu Crashes Firefox

Reported by: demoness@… Owned by: bill
Priority: high Milestone:
Component: General Version: 0.2
Keywords: Cc:
Blocked By: Blocking:

Description

In http://archive.dojotoolkit.org/nightly/tests/widget/ and http://archive.dojotoolkit.org/nightly/tests/widget/test_Menu2.html, when you right-click in Firefox the context menu comes up, but if you right-click again, or sing-click anywhere else without actually following a menu item, it crashes the browser.

Change History (7)

comment:1 Changed 13 years ago by bill

Milestone: 0.3release
Owner: changed from anonymous to bill
Status: newassigned

I don't see the crash but I did notice that there's no way to erase the menu by clicking outside of it, and that needs to be fixed.

comment:2 Changed 13 years ago by demoness@…

I should note that this is 1.0.7 on a Windows XP PC if that helps at all. I haven't had a chance to try it on any other machines. I wonder if it's a conflict with an extension?

comment:3 Changed 13 years ago by demoness@…

Okay, really bizarre. Apparently, just my version of Firefox is causing the crash. I've had other people try the same version and older and there's no problem. Must be gremlins. Going to try to troubleshoot it from that end.

comment:4 Changed 13 years ago by cal

i'm seeing this error in console:

Error: uncaught exception: [Exception... "Component returned failure code: 0x8000ffff (NS_ERROR_UNEXPECTED) [nsIDOMNSDocument.getBoxObjectFor]" nsresult: "0x8000ffff (NS_ERROR_UNEXPECTED)" location: "JS frame :: file:///C:/www/dojo-trunk/src/bootstrap1.js :: anonymous :: line 491" data: no]

it's caused by this line inside src/widgets/Menu2.js:

if (this.currentButton && dojo.html.overElement(this.currentButton, e)){

comment:5 Changed 13 years ago by cal

it's really caused by this block in src/style.js:

}else if(document.getBoxObjectFor){

mozilla var bo=document.getBoxObjectFor(node); ret.x=bo.x; ret.y=bo.y;

}else{

trying to find out what the deal is from bill who last modified this...

comment:6 Changed 13 years ago by cal

Resolution: fixed
Status: assignedclosed

was a problem passing an array of two ints where we expected a node. fixed in src/widgets/Menu2.js r3671

comment:7 Changed 12 years ago by (none)

Milestone: 0.3release

Milestone 0.3release deleted

Note: See TracTickets for help on using tickets.