Opened 12 years ago

Closed 11 years ago

Last modified 11 years ago

#6438 closed task (fixed)

BorderContainer: should have border on slider

Reported by: bill Owned by: nonken
Priority: high Milestone: 1.2
Component: Dijit - LnF Version: 1.1.0
Keywords: alex Cc:
Blocked By: Blocking:

Description (last modified by bill)

See http://download.dojotoolkit.org/release-1.1.0/dojo-release-1.1.0/dojox/layout/tests/test_ExpandoPane.html.

Splitters don't have their own borders, making them appear to "end" at the wrong place when what they butt up against doesn't include a border.

Taken from Alex's email.

Attachments (2)

border.png (10.7 KB) - added by bill 12 years ago.
ie6.png (6.8 KB) - added by bill 12 years ago.
problem with horizontal splitter on IE6

Download all attachments as: .zip

Change History (20)

Changed 12 years ago by bill

Attachment: border.png added

comment:1 Changed 12 years ago by bill

Description: modified (diff)

comment:2 Changed 12 years ago by bill

See also #6437. Be careful that fixing this "problem" could exacerbate that one.

comment:3 Changed 12 years ago by bill

And also, #6460.

comment:4 Changed 12 years ago by bill

(In [13740]) Fix bug w/doLayout=true mode where it would effectively double the ContentPane?'s padding, but setting a style="left: 5px; top: 5px;" on the child even though it isn't position:absolute.

Refs #6438. !strict

comment:5 Changed 12 years ago by bill

(In [13897]) Layout widget class changes:

  • Add class attribute to all layout widgets to control class name on domNode (dijitTabContainer, dijitBorderContainer, etc.)
  • Children of layout containers get composite classname specifying parent. ex: a ContentPane? inside of a BorderContainer? will get the class "dijitBorcontainer-dijitContentPane". This is to replace "dijitBorderContainer > dijitContentPane" type selectors which don't work on IE6.
  • refactor of addChild()/removeChild()/_setupChild() to share common code

Refs #6437, #6438 (these changes are necessary to setup CSS rules to get borders to show up correctly for various parent/child relationships)

!strict

comment:6 Changed 12 years ago by nonken

Resolution: fixed
Status: newclosed

Closed, Refs #6437, #6764

comment:7 Changed 12 years ago by nonken

To clarify, splitters should not have borders since the direct children of a BorderContainer? will provide the borders to make the sliders appear bordered.

Changed 12 years ago by bill

Attachment: ie6.png added

problem with horizontal splitter on IE6

comment:8 Changed 12 years ago by bill

Resolution: fixed
Status: closedreopened

I'm just seeing one problem w/the horizontal splitter in themeTester.html on IE6. There's no top border (IE, presumably the bottom border of the top TabContainer? is getting cutoff):

problem with horizontal splitter on IE6

Can we fix that somehow?

comment:9 Changed 11 years ago by bill

Milestone: 1.31.2

comment:10 Changed 11 years ago by bill

Resolution: fixed
Status: reopenedclosed

(In [14392]) Make BorderContainer panes have a higher z-index than the splitters so that off-by one errors don't obscure the border on the panes. Fixes #6438 !strict.

comment:11 Changed 11 years ago by bill

(In [14410]) Fix regression from [14392] breaking gutters=false. Refs #6438, fixes #7161.

comment:12 Changed 11 years ago by bill

(In [14426]) Rollback accidental checkin of experimental change in [14410]. Fixes #7166, refs #6438, #7161.

comment:13 Changed 11 years ago by Adam Peller

(In [14540]) Make example look nice again by cluttering markup :-P refs #6438

comment:14 Changed 11 years ago by bill

One of the fixes for this ticket was [14569], which added the tabStrip=true parameter. Note that the sliders don't really have borders, it's the panes themselves.

comment:15 Changed 11 years ago by bill

(In [16055]) Should use tabStrip=true on TabContainer?'s inside of BorderContainer?, to make it visually look right. Refs #6438.

comment:16 Changed 11 years ago by bill

[14426] was rolled back in [15206], thus in test_Gui.html on IE6 some of the borders (like the tabs w/labels on the right, the bottom border isn't showing up.

comment:17 Changed 11 years ago by bill

Oops,meant to say that: [14392] was rolled back in [15206], , thus in test_Gui.html on IE6 some of the borders (like the tabs w/labels on the right, the bottom border isn't showing up.

comment:18 Changed 11 years ago by bill

(In [16064]) Give splitters a high z-index on FF, low on IE, so that FF correctly shows splitter focus, but that on IE the splitters don't cover up the borders of panes.

Also fixes problem seen in themeTester.html (non-active sizing) where the splitter being dragged appears behind the stationary splitters.

ISTM that FF/high-contrast focus on splitters is still very difficult to see though, both before and after this change.

Refs #6438, #7583.

Note: See TracTickets for help on using tickets.