Opened 8 years ago

Closed 7 weeks ago

#6427 closed enhancement (patchwelcome)

ComboButton: option to move selection up to button

Reported by: bill Owned by: pruzand
Priority: high Milestone: 1.13
Component: Dijit Version: 1.1.0
Keywords: ibm Cc:
Blocked by: Blocking:

Description (last modified by bill)

Ability to have a ComboButton where the drop down makes a selection and then that selection becomes the button text and function. This is seen on editor toolbars for things like a color picker, but could also apply to drop down menus.

This also entails supporting the idea (and visualization) of a *selected* item on ColorPalette and on Menu, as a distinct concept from the currently focused/hovered item.

Not sure if this is a separate widget or how to implement etc. Needs some thought.

Taken from IBM Design Leadership recommendations.

Change History (11)

comment:1 Changed 8 years ago by bill

  • Description modified (diff)

comment:2 Changed 8 years ago by doughays

  • Type changed from task to enhancement

comment:3 Changed 7 years ago by bill

  • Milestone changed from 1.4 to 1.5

bumping 1.4 tickets to 1.5, and most 1.3 tickets to 1.4

comment:4 Changed 7 years ago by bill

See also #8193.

comment:5 Changed 7 years ago by scottlewis

This was ours. We decided the behavior is fine and this ticket can be canceled.

comment:6 Changed 7 years ago by doughays

  • Resolution set to wontfix
  • Status changed from new to closed

comment:7 Changed 7 years ago by scottlewis

  • Resolution wontfix deleted
  • Status changed from closed to reopened

Sorry for the confusion. My comment was intended for another ticket. This ticket should remain open.

comment:8 Changed 6 years ago by doughays

  • Milestone changed from 1.5 to future

comment:9 Changed 4 years ago by bill

  • Blocking 6507 added

comment:10 Changed 22 months ago by bill

  • Component changed from Dijit - LnF to Dijit
  • Owner changed from doughays to pruzand
  • Status changed from reopened to assigned

comment:11 Changed 7 weeks ago by dylan

  • Milestone changed from future to 1.12
  • Resolution set to patchwelcome
  • Status changed from assigned to closed

Given the lack of interest over the past 5+ years, I'm closing as patchwelcome. Please re-open if you want to create a pull request.

Note: See TracTickets for help on using tickets.