Opened 11 years ago

Closed 11 years ago

#6415 closed defect (invalid)

StackContainer: contents does not fit in Firefox Window

Reported by: guest Owned by:
Priority: high Milestone:
Component: Dijit Version: 1.1.0
Keywords: Cc:
Blocked By: Blocking:

Description

Hello,

I am facing a problem of containing the contents inside a Stack Container on Mozilla. The problem is that the contents do not fit in the browser.

I use this

DIV dojoType="dijit.layout.ContentPane" id="summary" name="summary"></DIV

to create a ContentPane? which is in turn defined inside something like this:

DV id = "wizard" doLayout="false" dojoType="dijit.layout.StackContainer?" style="width: 100%; border:0px solid #9b9b9b;margin: 0.1em 0 0.1em 0; padding: 0.1em;"> </DV

Now when the contents / data is too large, they do not fit in the browser (Mozilla). In IE, it fits in perfectly.

I use this to create my table: var res= document.createElement("table"); var body=document.createElement("tbody"); res.appendChild(body);

Is there a problem with the way I am appending the contents?

Or is there a problem with respect to Mozilla + Dojo 1.1?

Please suggest a fix for this. Let me also add that this is the same case with dojo 1.0.2, 0.9 and the latest version as well which I am using currently.

Thanks so much!! Bharath.

Attachments (4)

testcase1.jpg (136.5 KB) - added by bill 11 years ago.
testcase2.jpg (132.2 KB) - added by bill 11 years ago.
Correct_Behavior_of_testcase1_in_IE.jpg (140.1 KB) - added by bill 11 years ago.
Correct_Behavior_of_TestCase2_in_IE.jpg (109.5 KB) - added by bill 11 years ago.

Download all attachments as: .zip

Change History (12)

comment:1 Changed 11 years ago by bill

Summary: Stack Container contents does not fit in Firefox WindowStackContainer: contents does not fit in Firefox Window

I don't understand where the table goes, if it's inside the DIV or vice-versa. And also, not sure what you mean by "doesn't fit inside the browser". Lots of pages don't fit inside the browser's viewport; that's why the browser displays a scroll bar.

Anyway, you'll need to attach a small test case reproducing the problem.

comment:2 Changed 11 years ago by guest

I have attached 4 screenshots of the problem. 2 of which depict the problem in Mozilla. And the other 2 behaving properly in IE.

Kindly take a look at this and let me know if you need more info. Would be more than happy to provide you with anything else if needed.

comment:3 Changed 11 years ago by bill

Priority: highnormal

Again, you'll need to attach a small test case reproducing the problem.

I see the problem from the screenshots but no idea how to reproduce, or fix.

Also, please attach images directly (as jpg or gif, rather than bmp)... RAR is bundled with neithers windows nor mac. (Perhaps it's on vista but it's not on XP or earlier windows.) I'll replace your RAR file with image attachments.

comment:4 Changed 11 years ago by guest

Hi,

The screenshots are from a web application on my machine. In order to reproduce it, I would have to send out the application (EAR file) and you would need to deploy it on an application server like tomcat / BEA weblogic / Websphere Application Server, Apache Server.

Please let me know if this is feasible from your end.

Shall try and see if you can reproduce it in any other way.

Changed 11 years ago by bill

Attachment: testcase1.jpg added

Changed 11 years ago by bill

Attachment: testcase2.jpg added

Changed 11 years ago by bill

Changed 11 years ago by bill

comment:5 Changed 11 years ago by guest

Please let me if this problem can be reproduced using the way I have mentioned.

comment:6 in reply to:  5 Changed 11 years ago by guest

Please let me "know" that is...

Replying to guest:

Please let me if this problem can be reproduced using the way I have mentioned.

comment:7 Changed 11 years ago by bill

Sorry, it's not feasible for us to deploy a whole weblogic app, but since dojo is client only (ie, browser only) software you should be able to produce a test case that's a single HTML file.... based on whatever WebLogic? is sending to your browser.

comment:8 Changed 11 years ago by bill

Resolution: invalid
Status: newclosed

I'm going to close this until we get a testcase.

I suspect the problem is the same as usual when people say this doesn't work, namely that they didn't put height: 100% on html and body. (See mail.html or other full screen demos for examples)

Note: See TracTickets for help on using tickets.