Opened 11 years ago

Closed 4 years ago

#6410 closed enhancement (patchwelcome)

[dojox.widget] ColorPicker should track onMouseDown, onMouseMove

Reported by: Adam Peller Owned by: dante
Priority: low Milestone: 1.13
Component: DojoX Widgets Version: 1.1.0
Keywords: Cc:
Blocked By: Blocking:

Description (last modified by Adam Peller)

right now, the selection (on the slider and grid) only changes on mouse up. Click and drag, and it lets the browser drag the graphic. I think the expected behavior would be to change the color and values as the user drags.

Change History (10)

comment:1 Changed 11 years ago by dante

(In [13416]) refs #6410 - start of mousedown and keyboard handling in ColorPicker? refs #6243 - removes dojox.widget.ColorPicker? replaced by dojox.form._ColorPicker without deprecation! If we find it necessary, we can put a stub in dojox.widget to alias the two, though can't during this checkin and might not even be necessary.

comment:2 Changed 11 years ago by bill

Milestone: tbd

mark all (open) tickets w/blank milestones to be "tbd"; their milestones need to be set to a version number or to "future"

comment:3 Changed 11 years ago by dante

Milestone: tbdfuture

comment:4 Changed 11 years ago by dante

Status: newassigned
Summary: dojox ColorPicker should track onMouseDown, onMouseMove[dojox.widget] ColorPicker should track onMouseDown, onMouseMove

comment:5 Changed 7 years ago by ben hockey

Priority: highlow

comment:6 Changed 7 years ago by bill

Milestone: future1.2
Resolution: fixed
Status: assignedclosed

[14250] moved ColorPicker back to dojox/widget.

I'm not sure what @peller was referring to in this ticket since even in 1.1 you can drag and drop on both the grid and the slider. The only issue is if you mouse down *not* on the handle (either the handle of the slider or the circle in the grid showing the current color). And that problem was fixed in 1.2.

Also not sure why @dante marked [13416] as "start of mousedown and keyboard handling". It seems like at least mousedown is completely working.

comment:7 Changed 7 years ago by Adam Peller

Milestone: 1.2
Resolution: fixed
Status: closedreopened

I think what I was suggesting is that while you drag the handles, the values (and the color selection) in the widget should change accordingly. Although it seems to work fine for the circle in the grid, I'm noticing that this still does not seem to work for the slider. Even mouse down + mouse up does not change the value, it only works when you click -- that's a bug, not an enhancement issue #15043

Mouse interactions with the slider and grid seem to be generally broken in Chrome in 1.7, though. I'll file a new ticket on that: #15042

Last edited 7 years ago by Adam Peller (previous) (diff)

comment:8 Changed 7 years ago by Adam Peller

Description: modified (diff)

comment:9 Changed 7 years ago by bill

Milestone: tbd

comment:10 Changed 4 years ago by dylan

Milestone: tbd1.12
Resolution: patchwelcome
Status: reopenedclosed

Given the lack of interest over the past 5+ years, I'm closing as patchwelcome. Please re-open if you want to create a pull request.

Note: See TracTickets for help on using tickets.