Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#6409 closed enhancement (fixed)

Widgets don't completely scroll into view when they receive focus.

Reported by: Joseph Scheuhammer Owned by: Douglas Hays
Priority: high Milestone: 1.2
Component: Dijit Version: 1.1.0
Keywords: Cc: Becky Gibson, davidb
Blocked By: Blocking:

Description

Consider "../dijit/tests/form/test_Slider.html". There are a couple of vertical sliders on this test page.

If the slider is not fully scrolled into view and the thumb is moved using the keyboard, then it is possible to move the thumb off of the viewable area of the page. It continues to move, but it is not visible.

Tested on FF2, FF3, IE7, IE6 (WinXP), and FF2, FF3 (Mac).

Attachments (2)

6409.patch (3.3 KB) - added by Douglas Hays 11 years ago.
new dijit.scrollIntoView
6409.2.patch (6.9 KB) - added by Douglas Hays 11 years ago.
new patch that handles nested scrollbars

Download all attachments as: .zip

Change History (12)

comment:1 Changed 11 years ago by bill

Owner: set to Douglas Hays

Giving to Doug, unless one of the a11y folks wants to grab it.

Changed 11 years ago by Douglas Hays

Attachment: 6409.patch added

new dijit.scrollIntoView

comment:2 Changed 11 years ago by Douglas Hays

Summary: Slider: Vertical sliders don't completely scroll into view when they receive focus.Widgets don't completely scroll into view when they receive focus.

comment:3 Changed 11 years ago by Joseph Scheuhammer

I tested keyboard support using "../dijit/tests/form/test_Slider.html" after applying 6409.patch (FF2, FF3, IE6, IE7 on WinXP, and FF2, FF3 on Mac OS X Tiger). It works well in terms of scrolling sliders fully into view (I didn't check any other widgets).

I did discover issues with IE6 and FF, which I traced to dojo.getComputedStyle(), and have filed a new ticket -- see 6657.

Changed 11 years ago by Douglas Hays

Attachment: 6409.2.patch added

new patch that handles nested scrollbars

comment:4 Changed 11 years ago by Douglas Hays

Resolution: fixed
Status: newclosed

(In [13710]) Fixes #6409 !strict. Redesigned dijit.scrollIntoView to handle horizontal scrolling, right-to-left, and nested scrollbars. Called scrollIntoView automatically onfocus of a widget. Added automated test.

comment:5 Changed 11 years ago by bill

Resolution: fixed
Status: closedreopened

comment:6 Changed 11 years ago by Douglas Hays

Resolution: fixed
Status: reopenedclosed

(In [14101]) Fixes #6409. Rewrote dijit.scrollIntoView. Added enhanced test files and a simple doh test.

comment:7 Changed 11 years ago by bill

Resolution: fixed
Status: closedreopened

I think this checkin caused a problem w/test_InlineEditBox.html, clicking the "state of purchase" ComboBox for the first time. It gets an exception that "parent is undefined" on FF3/mac and Safari/mac at least.

Can you check if this is the cause? (If not can open other ticket instead)

comment:8 Changed 11 years ago by Douglas Hays

This was and is fixed. The unrelated InlineEditBox? problem appars to be caused by bill's [13989] change.

comment:9 Changed 11 years ago by Douglas Hays

Resolution: fixed
Status: reopenedclosed

comment:10 Changed 11 years ago by bill

As per above problem (my previous comment), see #7395.

Note: See TracTickets for help on using tickets.