Opened 12 years ago

Closed 11 years ago

#6397 closed enhancement (fixed)

Spinner: Home/End key strokes should set value to minimum/maximum.

Reported by: Joseph Scheuhammer Owned by: Becky Gibson
Priority: high Milestone: 1.2
Component: Accessibility Version: 1.1.0
Keywords: Cc: davidb
Blocked By: Blocking:

Description

As an enhancement for keyboard users, consider having the Home and End keystrokes set the value of a spinner to its minimum/maximum, respectively.

Presently, on WinXP, Home/End? moves the text entry cursor to the beginning/end of the text field component of the spinner (FF2, FF3, IE7, and IE6).

On Mac, Home/End? does nothing (FF2, FF3).

Change History (4)

comment:1 Changed 12 years ago by bill

Hmm, I wouldn't necessarily use the words "should" or "enhancement", as users might well be expecting home and end to work the way they work now, namely the expected behavior for <input>s. I'd be inclined not to do this although willing to hear other opinions.

comment:2 Changed 12 years ago by Joseph Scheuhammer

Would prefer "could" :-)?

First, how do desktop spinners use the Home/End? keys (if at all)? That behaviour needs to be balanced against what users expect <input>'s to to do.

Secondly, I'm partially influenced by the DHTML style guide, a best practices document: http://dev.aol.com/dhtml_style_guide#spinner

This document is not final, and if its prescription for Home/End? is wrong, that should be brought up with that group.

Finally, the text entry field is small, whereas the spinner range could be large. Users might appreciate quick access to the max/min values over the beginning/end of the text entry field.

comment:3 Changed 11 years ago by Becky Gibson

Status: newassigned

I have some qualms about overriding the home/end behavior of the input field attached to the spinner to move the cursor to the begining/end of the field. But since it is a spinner (and not a plain input field), I have been convinced that having keystrokes to quickly move to the min and max values is worthwhile. The user can use the left/right arrow keys to move the cursor.

comment:4 Changed 11 years ago by Becky Gibson

Resolution: fixed
Status: assignedclosed

(In [14388]) fixes #6397 Based on recommendations of keyboard style guide, Added support for home/end key to quickly set value to min/max via the keyboard. Home/end key swallowed if no home/end value specified in order to provide consistent behavior.

Note: See TracTickets for help on using tickets.