Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#6361 closed defect (invalid)

SplitContainer->BorderContainer: overlap bug?

Reported by: haysmark Owned by: Adam Peller
Priority: high Milestone: 1.1
Component: Dijit Version: 1.1.0
Keywords: Cc:
Blocked By: Blocking:

Description

I am converting a SplitContainer? to a BorderContainer?. The SplitContainer? I am referring to is the second one, to the right, on this page: http://archive.dojotoolkit.org/nightly/dojotoolkit/dijit/tests/layout/test_SplitContainer.html

Its code looks like this:

<div dojoType="dijit.layout.SplitContainer"
	orientation="horizontal"
	sizerWidth="7"
	activeSizing="true"
	style="border: 1px solid #bfbfbf; float: left; width: 400px; height: 300px;">
	<div dojoType="dijit.layout.ContentPane" sizeMin="20" sizeShare="20">
		this box has two horizontal panes
	</div>
	<div dojoType="dijit.layout.ContentPane" sizeMin="50" sizeShare="50">
		with active resizing, a smaller sizer, different starting sizes and minimum sizes
	</div>
</div>

I followed the release note guidelines for converting SplitContainers? to BorderContainers? and got this:

<div dojoType="dijit.layout.BorderContainer" 
	liveSplitters="true"
	style="border: 1px solid #bfbfbf; float: left; width: 400px; height: 300px;">
	<div dojoType="dijit.layout.ContentPane" region="leading" minSize="20" splitter="true">
		this box has two horizontal panes
	</div>
	<div dojoType="dijit.layout.ContentPane" region="trailing" minSize="50">
		with active resizing, a smaller sizer, different starting sizes and minimum sizes
	</div>
</div>

However, this conversion produced some messy results:

BorderContainer created from old SplitContainer

Is this really the intended behavior?

Attachments (1)

bordercontainer1.JPG (8.5 KB) - added by haysmark 12 years ago.
BorderContainer? created from old SplitContainer?

Download all attachments as: .zip

Change History (3)

Changed 12 years ago by haysmark

Attachment: bordercontainer1.JPG added

comment:1 Changed 12 years ago by Adam Peller

Resolution: invalid
Status: newclosed

BorderContainer? MUST have a center region. I will update the docs to reflect this.

comment:2 Changed 12 years ago by Adam Peller

Milestone: 1.1.11.1
Note: See TracTickets for help on using tickets.