Opened 12 years ago

Closed 11 years ago

#6352 closed defect (worksforme)

TextTimeBox: esc does not revert to most recently entered date in IE6 and IE7 when the date is preset on load.

Reported by: Joseph Scheuhammer Owned by: haysmark
Priority: high Milestone: 1.2
Component: Accessibility Version: 1.0
Keywords: Cc: davidb
Blocked By: Blocking:

Description

.../dijit/tests/form/test_DateTextBox.html

For example: "Date (local format - long)". This DateTextBox is preset to "December 30, 2005".

  1. Type in a new date and hit tab.
  2. Shift-tab back to the DateTextBox.
  3. Erase the date in the box.
  4. Hit esc.

For FF2, FF3 Win/Mac?, the value reverts to the new date entered at the first step.

For IE6 and IE7, it reverts back to the original preset date of "December 30, 2005".

In fact, in IE6 and IE7, the date can be changed repeatedly, but the instant esc is pressed in an empty box, it reverts back to the preset "onload" date.

Change History (5)

comment:1 Changed 12 years ago by Becky Gibson

Cc: haysmark added
Owner: changed from becka11y to Douglas Hays

comment:2 Changed 12 years ago by bill

Milestone: 1.1.11.2

OK, this doesn'tseem critical for me. It doesn't make the product unusable (even for people that can't use a mouse).

comment:3 Changed 12 years ago by Douglas Hays

Cc: haysmark removed
Owner: changed from Douglas Hays to haysmark

comment:4 Changed 12 years ago by haysmark

I can't reproduce this anymore.

comment:5 Changed 11 years ago by haysmark

Resolution: worksforme
Status: newclosed
Note: See TracTickets for help on using tickets.