Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#6320 closed defect (fixed)

demo_ActionWiring: does it actually search?

Reported by: haysmark Owned by: Jared Jurkiewicz
Priority: high Milestone: 1.1.1
Component: DojoX Wires Version: 1.1b1
Keywords: Cc:
Blocked By: Blocking:

Description (last modified by Jared Jurkiewicz)

See: http://archive.dojotoolkit.org/nightly/dojotoolkit/dojox/wire/demos/markup/demo_ActionWiring.html

It seems that no matter what I type in, it always returns the full list.

Also, the order that the first few cities appear is different between IE7 and FF, which is a little weird . . .

FF: Nairobi city Toronto city Ottawa city Khartoum city Mexico City city Mombasa city Guadalajara city

IE7: Nairobi city Mombasa city Khartoum city Mexico City city Guadalajara city Ottawa city Toronto city

Change History (6)

comment:1 Changed 11 years ago by Jared Jurkiewicz

Description: modified (diff)

Used to. Don't know what changed. Will investigate.

comment:2 Changed 11 years ago by Jared Jurkiewicz

Order is irrelevant in the demo. No sort options were specified, so the order returned is indeterminant.

comment:3 Changed 11 years ago by Jared Jurkiewicz

The problem is caused by a breaking API change in dojo 1.1. dijit.form.TextBox? removed a public event, onkeyup().

http://trac.dojotoolkit.org/ticket/6320

That was what was used to clone over the search params each time you typed in the textbox. Now without that event, it would have to be a different event. Waiting to see what the conclusion is on 6320 before I make any drastic changes.

comment:4 Changed 11 years ago by Jared Jurkiewicz

Correction: http://trac.dojotoolkit.org/ticket/6489

Is the cause. It also breaks the following demos: dojox/wire/demos/markup/demo_ActionChaining.html dojox/wire/demos/markup/demo_TopicWiring.html

comment:5 Changed 11 years ago by Jared Jurkiewicz

Resolution: fixed
Status: newclosed

According to Doug, this should be fixed in 1.1.1. They put the event back.

comment:6 Changed 11 years ago by bill

Milestone: 1.1.1
Note: See TracTickets for help on using tickets.