Opened 13 years ago

Closed 13 years ago

#631 closed defect (duplicate)

Split Page widget Virtual Sizer doesn't work on java applet element in IE 6.0

Reported by: tomek@… Owned by: koranteng
Priority: high Milestone: 0.9
Component: Widgets Version: 0.2
Keywords: widget applet Cc: peter@…; greg@…
Blocked By: Blocking:

Description

I am using Split Page widget in my application and I found problem when using java applet in my application. The Virtual Sizer element is not showing when draging over the applet and, which is most important, it doesn't throwing the onmouseup event when trying to drop it over the applet, I noticed the you already resolved this problem in Dialog widget ( bgIframe field ), using dojo.html.BackgroundIframe? class, could you implement the same solution for the virtual sizers in Split Pane widget class ?

Change History (8)

comment:1 Changed 13 years ago by anonymous

Milestone: 0.3release0.3.1
Version: 0.20.3

comment:2 Changed 13 years ago by anonymous

Version: 0.30.2

comment:3 Changed 13 years ago by alex

the issue here isn't that we don't have a bgiframe on the slider since the slider isn't what "hears" events during the drag operation. In effect, mousing over the applet causes events that would otherwise be generated to be "snarfed". We might be able to fix this by putting a transparent div over the contents of the panes, but this strikes me as somewhat heavyweight.

comment:4 Changed 13 years ago by bill

Milestone: 0.3.10.4

this looks hard to fix. punting.

comment:5 Changed 13 years ago by dylan

Milestone: 0.40.5

comment:6 Changed 13 years ago by dylan

Owner: changed from anonymous to bill

comment:7 Changed 13 years ago by koranteng

Owner: changed from bill to koranteng

comment:8 Changed 13 years ago by koranteng

Resolution: duplicate
Status: newclosed

Duplicate of #2000, #1229, #1044

fixed (In [7453]) by introducing a div to cover the entire area occupied by a splitcontainer. the div is under the sizer

Note: See TracTickets for help on using tickets.