Opened 12 years ago

Closed 10 years ago

#6275 closed defect (fixed)

dojox.fx.sizeTo Behavioral Defect?

Reported by: ole.ersoy@… Owned by: dante
Priority: high Milestone: 1.4
Component: Dojox Version: 1.0
Keywords: Cc:
Blocked By: Blocking:

Description (last modified by dante)

This is not necessarily a bug. I'll just describe the setup and end result, and let you be the judge.

I changed the duration on the sizeTo animations in the sizeTo test to 550. Now if I move the mouse over the "Hover/exit" animation, such that it is only over the node for an instant, the animation that collapse the node gets stuck. It appears that the second animation in the chain that collapses the node back down does not execute.

Here are the parts that I changed (Only the duration):

        var test1 = function(e){
                // this is our click test,
                dojox.fx.sizeTo({
                        node: e.target,
                        width: 120,
                        height:120,
                        duration:550                        
                }).play(5);
        };
        
        var testundo = function(e){
                dojox.fx.sizeTo({
                        node: e.target,
                        width:50,
                        height:50,
                        duration:550                        
                }).play(5);
                
                
        };
        
        var test2 = function(e){
                dojox.fx.sizeTo({
                      node: e.target,
                      width: 120,
                      height:120,
                      duration:550,
                      method:"combine"
                }).play(5);
        };

SO if you make similar changes and try it, you should see the same effect. I ran the test in firefox 2.0.

Cheers,

  • Ole

Change History (11)

comment:1 Changed 12 years ago by guest

If the testundo method is set to "combine", then the node collapse no regardless of the time interval that the mouse hovers for.

var testundo = function(e){

dojox.fx.sizeTo({

node: e.target, width:50, height:50, duration:550, method:"combine"

}).play(5);

comment:2 Changed 12 years ago by dante

Owner: changed from anonymous to dante

comment:3 Changed 12 years ago by guest

This is OT. I just noticed that the testundo connects to "onmouseenter", which according to this is microsft only.

http://www.quirksmode.org/js/events_mouse.html

I'm assuming it's better for future testers, if "onmouseover" is used instead.

comment:4 Changed 12 years ago by bill

Cc: ole.ersoy@… removed
Component: Generalfx
Description: modified (diff)
Reporter: changed from guest to ole.ersoy@…

Not sure which test you are talking about, but onmouseenter is supported across all browsers by dojo, see #4307.

comment:5 Changed 12 years ago by bill

Component: fxDojox
Summary: dojo.fx.sizeTo Behavioral Defect?dojox.fx.sizeTo Behavioral Defect?

Oh apparently you are talking about dojox.fx.

comment:6 in reply to:  4 Changed 12 years ago by guest

Replying to bill:

Not sure which test you are talking about, but onmouseenter is supported across all browsers by dojo, see #4307.

Oh Sweet - Thanks for pointing that out.

comment:7 in reply to:  5 Changed 12 years ago by guest

Replying to bill:

Oh apparently you are talking about dojox.fx.

Indeed - Sorry for the late reply btw - I've been on vacation.

comment:8 Changed 11 years ago by bill

Milestone: tbd

mark all (open) tickets w/blank milestones to be "tbd"; their milestones need to be set to a version number or to "future"

comment:9 Changed 11 years ago by dante

Description: modified (diff)
Milestone: tbdfuture

i'd really like to address this

comment:10 Changed 11 years ago by ole

Just adding a cross reference to a closed ticket, marked as a duplicate of this one:

http://bugs.dojotoolkit.org/ticket/6369

Are we sure that these are duplicates? They seems different to me.

comment:11 Changed 10 years ago by dante

Milestone: future1.4
Resolution: fixed
Status: newclosed

I believe this was fixed as part of my Animation enhancenment. Now, anytime a start value is needed, the calculations are done on the fly.

Note: See TracTickets for help on using tickets.