Opened 12 years ago

Closed 12 years ago

#6239 closed defect (fixed)

Tree: wiggling expando causes drag of another node

Reported by: bill Owned by: bill
Priority: high Milestone: 1.1
Component: Dijit Version: 1.0
Keywords: Cc:
Blocked By: Blocking:

Description (last modified by bill)

On IE or FF, open test_Tree_DnD and try:

  • drag "Orange" from "Citrus" to "Cereals" (and drop on "Cereals")
  • mouse down on Cereal's expando icon (ie, the + sign)
  • wiggle the mouse a bit (w/out releasing the left mouse button)... OR mouse-down anywhere to the left of the tree...

Strangely, the drag icon for "Orange" appears! (This was the cause of "Cereals" becoming a leaf as mentioned in #6232). Releasing the mouse at this point seems to delete Orange, or perhaps makes it a top level node (but it doesn't appear visually for some reason).

Change History (3)

comment:1 Changed 12 years ago by bill

Description: modified (diff)

comment:2 Changed 12 years ago by bill

Turns out this isn't a bug per se, but rather something that's confusing because:

  • even after dropping nodes they are still selected (I could change this behavior for tree but then it wouldn't be consistent with normal DnD)
    • mouse down+mouse move anywhere in the container (which in this case is the whole Tree) will start a move of the selected nodes.

So, in various cases you can move nodes that are hidden, but in particular this case is confusing since the user didn't explicitly hide the node.

comment:3 Changed 12 years ago by bill

Resolution: fixed
Status: newclosed

(In [13123]) Expand tree node when you drop something into it, to prevent confusion when user accidentally starts a new drag operation. Fixes #6239.

Note: See TracTickets for help on using tickets.